Upgraded Windows 8 to Windows 10, now hard drives failing

Discussion in 'Windows, Linux & Others on the Mac' started by cornz, Aug 5, 2015.

  1. cornz macrumors newbie

    Joined:
    Aug 5, 2015
    #1
    Device: MacBook Pro 9,1 (15-inch unibody mid-2012), 750GB HDD, partitioned to 600GB OS X, 150GB Windows.

    The past two days have pretty much been my technological nightmare, that I have been wondering about for years... Would something like this ever happen to me? The answer is yes. I am writing this both for help, as well as a reference point for anyone else who might come across this.

    I innocently enough decided to upgrade from Windows 8 to Windows 10. In order to do this, I first upgraded to Windows 8.1, which took long enough, and took the next step to Windows 10. Great! All done, after a massive struggle (I remember why I prefer OS X..)

    During the installation process, because my default startup hard drive was set as Macintosh HD, I several times killed the boot process by holding the power button due to Windows wanting to restart.

    After waking up the day after starting the Windows 10 install process, I came to my laptop which had hung about halfway through the startup process. I thought nothing of it, killed it again, and tried to boot up. Nothing! It shut itself down at the halfway mark.

    I took my MacBook Pro with me to university and troubleshooted using:
    • Diagnostics (holding down D during startup, came up with nothing)
    • Recovery, pretty much useless. Tried to repair the disk three or four times. Each time, it let me know that the drive could not be repaired and I should format it.
    • Single user mode and ran fsck many times, came up with incorrect number of thread records (4, 23745) every time.
    Now funnily enough! The Windows 10 partition was 100% fine, it even mounted and allowed me to access my Macintosh HD! Which leads me to believe that there is something funky going on with either Windows or OS X. The hard drive itself was clearly physically intact and operating normally.

    I took it to my local Apple store, where they tried some diagnostics but quickly realised that the hype was real. They kindly replaced my hard drive and hard drive cable for no charge. Wonderful, everything is dandy, fsck Windows 10. Right?

    Except.. I've just come home and plugged in my external WD hard drive that I used to back up the 500GB of data I had on my previous drive, and this one is exhibiting the exact same symptoms. Won't repair, won't mount, won't unmount, won't eject, won't allow fsck to be run because it's 'busy'.

    By some miracle as I was typing this, the volume finally mounted. I hit Verify Disk in Disk Utility and it let me know that "The volume corn appears to be OK." Psh.

    But it certainly has scared me to bits and I'm moving everything important off, and formatting the drive as soon as possible.

    So what happened here? Did Windows screw up my drives? Or was it completely coincidental? Do I have some corrupt files, or am I the lucky winner of a 'firmworm' infection that everyone is going crazy about in the news? Let me know your theories.

    Footnote, I did try mounting my external drive on a different mac, and it also came up the same way, unresponsive, Repair Disk came back with 'Cannot repair', etc. The external drive is exFAT. The Macintosh HD was HFS+.

    Let me know your thoughts.
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    I admit I know few about your issue. But I have another weird issue when trying to remove windows partition from mac using boot camp assistant.

    The main reason I suppose many users prefer mac OS X is because mac OS X packs up all basic things you may need inside system, and you don't even need to be bothered to dig into them if system goes fine. This is a very typical way Linux or Unix system uses when installing operating system onto user computer. They simply know their software support is far weaker than windows counterpart.

    So, DIY is a rarely-heard noun in mac world. Mac users knows simply how to use their mac, and everything is done.
     
  3. flyinmac macrumors 68030

    flyinmac

    Joined:
    Sep 2, 2006
    Location:
    United States
    #3
    I had my OS X partition corrupted the other day also. It happened when I reinstalled vista (which had previously already been there) over itself. And then reinstalled the boot camp drivers from Apple.

    Apples boot camp drivers enable Windows to read OS X / mac drives. But Apple's drivers are buggy. They have a reputation for causing trouble.

    Everything was fine until I installed the boot camp drivers. Suddenly my OS x partition was in bootable (despite not even being on the same hard drive as my windows installation).

    I got all the same errors you did. Disk utility was unable to repair the drive.

    I booted from an external drive, copied the files off the corrupted drive, formatted and reinstalled OS x.

    I also upgraded to windows 10 at the same time (avoiding boot camp like the plague). Everything has been fine ever since.

    My memory tells me I've been through this years ago, and now I remember why my Vista install wasn't able to read my OS X drives (because I'd disabled that the last time this happened).

    It's not your hardware, it's not Windows, it's Apple's buggy drivers.

    Avoid boot camp. Install the drivers you need manually. If you use boot camp, do not install the drivers that allow Windows to read OS X drives.
     

Share This Page