Upgrd to 3.0 w/T-Mobile SIM & Turbo SIM Accdntly in Phone/Itunes says Sim not Support

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Chavi, Jul 6, 2009.

  1. Chavi macrumors newbie

    Joined:
    Jul 5, 2009
    #1
    Hey all, i have an Iphone 3g. It was running 2.2.1 JB and UL using a Turbo Sim to connect to T-Mobile. My issue started when I was going to upgrade to 3.0. I started the upgrade process with the T-Mobile SIM inside the phone along with the Turbo Sim. After a few minutes, I realized what I was doing and replaced it with an active ATT Sim. Well... after it finished upgrading to 3.0 Itunes prompts me with the error "The SIM card inserted in this Iphone does not appear to be supported". This happens after I have placed the ATT Sim in the phone.

    I then continued to do an Option+Restore restoring the patched IPSW, iPhone1,2_3.0_7A341_Restore.ipsw and still no luck. I then restored to the factory IPSW with same result on a mac and pc!!! Anyone please help... this is my moms Iphone and I'm pissed at myself for making that stupid mistake.

    Thanks guys!
     
  2. mcmanus7 macrumors 6502a

    Joined:
    Oct 30, 2008
    #2
    As far as I know... once you get that error the iPhone is "Bricked"... the only way that I know of getting it to work again is to get your phone swapped out by apple...
     
  3. hthassan macrumors newbie

    Joined:
    Jul 10, 2009
    #3

    Simple solution:

    Close iTunes, open RedSnow (to jailbreak your iPhone) and redsnow would activate it for you.. and then simply install ultrasn0w from Cydia and you can use your T-Mobile sim card.
     
  4. squirrelking macrumors newbie

    squirrelking

    Joined:
    Jul 10, 2009
    Location:
    Evans, CO
    #4
    Hthassan has it! Use Redsnow and it'll fix the problem.. I was able to get an iPhone out of a pretty bad state by just using Redsnow and when it was all said and done, it was fixed, JB'd and UL'd (once installing Ultrasn0w)..
     

Share This Page