Uploaded photos lost during unsuccessful I-Photo upgrade

Discussion in 'Mac Apps and Mac App Store' started by RayleighM, Oct 9, 2010.

  1. RayleighM macrumors newbie

    Joined:
    Oct 9, 2010
    #1
    As an Apple novice I have a problem using I-photo Library Manager.

    Having just got back from holiday, I tried to move all the holiday photos made from our old MacBook to our new iMac.
    (During the holiday I uploaded all the pics from the cameras memory card to our MacBook laptop that we took with us).

    Strangely found it was not possible to transfer the pics from the laptop to the iMac so I downloaded a program I-photo Library Manger onto the iMac to solve the problem.

    I added the macbook's I-photo library onto the Library Manager on the iMac
    and could now see all the macbooks albums and events.

    Although when I went to click on the newly added library, I was prompted to close the current library of my iMac. So I closed I-Photo on the iMac and then was prompted with a message saying something like... 'important updates need to be installed, to incorporate important changes references'.

    I clicked update now and waited quite a long time. After it had finished installing the updates I went back into Library Manger Program on iMac and saw that the newly added library (of which I could first see all the albums) was now showing in red and not able to open anymore. I believe what happened is that the Library Manger program on the iMac was trying to sync with the older MacBook (which runs on Leopard 10.5.8) and not able to do so.

    Then went into my MacBook and tried to open I-Photo but got the message: "You cant open your current Photo Library using this version of I-Photo. You have made changes to your Photo Library using a newer version of I-Photo. Please quit and use the latest version of I-Photo"

    There is only a 'Quit' button showing and underneath the text 'Loading Photos...' with the perpetual loading circle. When I click on 'Quit' the program closes so I cannot get to my photos on my Macbook anymore.

    So I tried to install the latest version of I-Photo 8.1.2 on the MacBook but this wont install because MacBook is not running on Snow Leopard.

    I then tried importing the older version of I-Photo onto the MacBook but the same Please quit message would appear.

    So the problem is that I cannot open my Iphoto program on my Macbook. Also if I access my albums and photos via the package content originals of I-photo library then I can see the latest event uploaded is missing.

    How to retrieve it back? And, should I deinstall the Photo Manager on my Imac? What did those updates do?

    Hope someone can shed some light and explain how to resolve problem.
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    Sounds like your 3rd party iphoto manager mangled your library. You do have a backup don't you? The big issue with 3rd party tools that try to monkey around with iPhoto or iTunes libraries is that they can easily cause an awful mess.
     
  3. Mr Kram macrumors 68000

    Mr Kram

    Joined:
    Oct 1, 2008
    #3
    did you try searching for your lost photos? it could be that they are toast.

    you don't need any third party utilities to move a library.

    see this.
     

Share This Page