URGENT HELP! phone sound and volume bar disappeared?

Discussion in 'iPhone' started by Ry., Jul 23, 2012.

  1. Ry. macrumors member

    Joined:
    Oct 6, 2011
    #1
    Hello There!

    Long story short, I dropped my iphone 4 in a basin of water earlier. I immediately turned off the phone, but for some weird reason, it came straight back on. again, I powered it off, up came the black screen, then the circular loading icon, then apple logo, then back to the home screen. The phone wont turn off.

    I then went to test the speakers using ipod app, and the volume bar has disappeared. Youtube also. The speakers do still work though as when I go into sounds from the settings app, it lets me adjust the ringtone volume, which plays fine through the speakers.

    I tried using the side volume buttons but It just comes up with the ringer logo with no increase/decrease bars.

    I use my iphone as my alarm clock so I need to fix this urgently. I plugged the phone into speakers but there is no volume bar so no sound even out the external speakers.

    Since the ringtone volume works through the phone speakers im guessing its a software issue that happened when the phone went in the water?

    Any help/suggestions would be welcome!

    Thanks.
     
  2. utr macrumors newbie

    Joined:
    Jul 23, 2012
    #2
    Try and clean the doc connector. I used tissue paper. I had that issue once (not dropped in water) but I think he phone thought it was connected to a docking station.
     
  3. Ry. thread starter macrumors member

    Joined:
    Oct 6, 2011
    #3
    Already cleaned it with a cotton bud to get any water out. Still not working :(
     
  4. needsmoar macrumors member

    Joined:
    Aug 3, 2010
    Location:
    Canada
  5. Ry. thread starter macrumors member

    Joined:
    Oct 6, 2011
    #5
    I restored the phone. problem still persists. the volume icon has "(headphones)" written when i change volume, even though there are no headphones in it. Still no volume from ipod or any apps, but volume comes back when I go to ringtone volume. Very strange!
     
  6. needsmoar macrumors member

    Joined:
    Aug 3, 2010
    Location:
    Canada
    #6
    http://iphonenosound.com/

    there is the site i came across when dealing with the problem.

    Its different for everyone but has some decent ideas. the rubbing alcohol/qtip worked for me after i used a brush. but pushing in the corner, dock/undocking and headphone in/out did nothing nor did restores or resets.

    Basically its stuck in dock mode thats why you still get rings, charger sounds. speakers are working.
     
  7. Grubster macrumors member

    Joined:
    Jun 25, 2010
    #7
    Take an air compressor and spray into the headphone jack. If you don't have an air compressor, take a can of compressed air to clean keyboards and photographs and such.

    You need to spray in there for like 10-30 seconds. I have fixed 3 iPhones like this.
     

Share This Page