URGENT! i need help!!! im stuck with a blocked iphone 2g on jailbraking 2.2

Discussion in 'Jailbreaks and iOS Hacks' started by lucamusic, Jan 11, 2009.

  1. lucamusic macrumors newbie

    Joined:
    Jan 11, 2009
    #1
    hi everyone
    i ve been trying to jailbreak a 2g iphone for 2.2 following the guide from the dev team
    ....apparently ive mistaken somewhere and beeing really stupid Ive updated from 2.1 to 2.2 direcly from itunes thinking that i could have jailbroken it later....

    now im stuck all i see from iphone is the request to connect it to itunes.
    ive tried to restore it to my custom 2.2 firmware but it would say error 21
    i can get to dfu mode as i cant actually turn of the iphone!

    please i need some help here
    thanx
     
  2. fuzzyhunger macrumors newbie

    Joined:
    Jan 11, 2009
    #2
    I am going through the same issue. What version of iTunes are you using? My boyfriend (an Apple employee) thinks there was something in the 8.0.2 iTunes update to prevent unlock/jailbreaks.
    I don't have a solution for you, unless you can downgrade your iTunes. That's the only thing I can think of that might solve it. I'm running OSX with non-admin restrictions, so my "simple" solution isn't that simple. I tried that when I went from 2.0.2 to 2.1.
    Hope you figure something out. I've been working on my phone all day with no luck. That heaven I have a back up phone.
     
  3. gacxx macrumors regular

    gacxx

    Joined:
    Oct 24, 2007
    #3
    I have a few questions

    What tool are you using (quickpwn, pwnage tool etc.) and which version? You can Jailbreak a 2.2 iphone but you need to be using the correct version of your tool.
     
  4. lucamusic thread starter macrumors newbie

    Joined:
    Jan 11, 2009
    #4
    ive got the 8.02 for itunes and not sure about the tool...ive tried a few, which one would u suggest? how can i downgrade itunes? anyone who has done this before?
    thankx
     
  5. taskmanager macrumors regular

    Joined:
    Jan 12, 2009
    #6
    Some of they guys at work ran into this issue. They were able to resolve it using a mac to admin it rather than a pc. For some reason the app on a pc didnt work well. Ill get more details tomorrow, when I'm not home sick
     
  6. gacxx macrumors regular

    gacxx

    Joined:
    Oct 24, 2007
    #7
    Since you updated to 2.2 already, your going to want to use quickpwn 2.2 or pwnage tool 2.2. Quickpwn is fast and easy, and does not require a restore. Do you have one of the new unibody macbooks or macbook pros?
     
  7. lucamusic thread starter macrumors newbie

    Joined:
    Jan 11, 2009
    #9
    ok so here are all the details.
    im using a mac pro 8 core leopard 10.5.6
    itunes 8.0.2

    my question is : was it a crucial mistake to update to 2.2 directly from from itunes ?

    is anyone in the same situation as mine with the iphone asking to connect to itunes?

    please help
    thx
     
  8. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #10
    The jailbreak/unlock should work fine with 2.2. just make sure you have the latest version of itunes and quickpwn (reinstall them, just incase). quick pwn should work faster and easier than creating a custom ispw. good luck!
     
  9. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #11
    I think it was a mistake upgrading to Leopard 10.5.6. They block DFU mode and when you restore with original firmware, it relocks everything. You need to patch your IOUSB kext or get a USB hub and connect to the computer using DFU mode on the iPhone through the USB hub.
     
  10. bronloco macrumors newbie

    Joined:
    Feb 10, 2009
    #12
    iphone blocked please help me

    hi i recently tried to upgrade my ihphone as itunes told me i should and now all i can do is make emergency calls and it keeps telling me to connect it to itunes. i have no idea what to do..please help me...anyone please
     
  11. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #13
    Connect it to iTunes and activate it
     
  12. Capio-Lumen macrumors newbie

    Joined:
    Oct 8, 2008
    #14
    +1+1


    I have heard that if your using a USB cable that's directly connected to your computer, 10.5.6 wont let you enter into DFU mode. You have to use a powered USB router and it should solve the problem. The dev team also posted another solution but its kind of complex. I used the a router and the first few times trying to enter into DFU mode I recieved the same ERROR that you did, after two attempts it went though, thought i was in the dog house for a sec.


    From the Dev Team...

    Fixing DFU mode on 10.5.6

    As noted previously OS X 10.5.6 introduced a bug that affected the use of DFU mode. with some Macs. There have been previously published hacks and techniques to fix this, but here is another method that can be used to temporarily restore DFU functionality in order to use QuickPwn or PwnageTool.

    1. You will need an account with ADC (Apple Developer Connection) this is free and takes a few minutes to sign up, you should read the terms and conditions carefully and you should only sign up if you are thinking of developing applications in the future - http://developer.apple.com/mac/
    2. Download the disk image “IOUSBFamily-315.4-log.dmg” for Mac OS X 10.5.5 Build 9F33” (yes, that is a “5” in 10.5.5 - this is a developer debug package of the USB kernel extension).
    3. Unplug non-vital USB equipment, such as external DVD writers, USB scanners, USB mass storage devices, at the most leave a Keyboard and Mouse connected.
    4. Install IOUSBFamily-315.4.1.pkg from within the disk image
    5. Reboot your system!
    6. Perform necessary DFU activity with QuickPwn or PwnageTool.
    7. Download the disk image “IOUSBFamily-327.4.0-log.dmg” for Mac OS X 10.5.6 Build 9G55”
    8. Intall IOUSBFamily-327.4.0.pkg from within the disk image
    9. Reboot your system!
    10. Reattach your USB peripherals.
     
  13. bronloco macrumors newbie

    Joined:
    Feb 10, 2009
    #15
    i did connect to itunes and it says that my sim is no longer supported??? i am really sorry but am not really clued up on computer terms so can someone explain this all to me in easier ways? i,m sorry to be a pain.:confused:
     
  14. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #16
    I guess it means that you are not using an AT&T iPhone SIM (if you're in the US) and that you do not have an unlocked phone.

    I am not a mindreader but if you upgraded an unlocked iPhone 3G through iTunes to the latest 2.2.1 then you have shot yourself in the foot and you'll have to get an AT&T contract.

    If you're just trolling, you can stop now.
     

Share This Page