[URGENT] Mac Pro 5.1 w/ EVGA GTX 970 SSC ACX 2.0+ no picture

Discussion in 'Mac Pro' started by ttminh1997, Oct 6, 2016.

  1. ttminh1997, Oct 6, 2016
    Last edited: Oct 6, 2016

    ttminh1997 macrumors newbie

    Joined:
    Oct 6, 2016
    #1
    Boy that was a long title. Anyways, to the main problem:

    I have a 2010 Mac Pro 5.1 base option (2.8ghz quad core). I just got the gtx 970 today, and followed all directions to install the web driver, and made sure that the system is actually using the web driver. Here are my steps:
    1. Install Web Driver version 367.15.10.05f01, which is compatible with macOS Sierra 10.12 (16A323) that I'm running. Install latest CUDA driver
    2. Restart
    3. Choose to use the NVIDIA web driver in the menu bar
    4. Restart
    5. Make sure that the system is actually using the web driver in system preferences
    6. Turn off machine
    7. Install card and power cables
    8. Turn on the machine
    At this point, I could still hear the start up chime, but I waited and waited and there simply was no signal to the monitor. I popped the old card back in and started trouble shooting. Here's what I tried
    • With the old card, I switched to OSX Driver, rebooted, switched back to web driver, rebooted again, made sure that it's using web driver, turn off, popped new card in again. No dice
    • With old card, I uninstalled web driver, but left CUDA driver intact, rebooted, install web driver again, go thru the 8 steps above again. Still no dice.
    There are a few anomalies that may or may not be relevant:
    • In the CUDA Preference panel, it says I have CUDA Driver version 8.0.46, and then a big red "Update Required" next to it, but when I tried to update, there's none available
    • Also in the CUDA Preference panel, it says: "GPU Driver Version: no version found". I thought this meant either the system wasn't using the web driver, so I checked and web driver was checked under the menu bar drop down. I then thought I might have botched the installation somehow, so I reinstalled as mentioned above, but still no signal
    • Moved the card to the 2nd PCIe x16 slot. No signal either
    • I only have 2 6 pins power cables, not 1 6 and 1 8. I don't know if this matters or not, but the folks at Create Pro said that the card could function with 225W unless I'm doing heavy gaming in Windows
    • Should there be a start up chime? I've read that there shouldn't be a start up chime.
    I now have the HD5770 back in, and everything is good so far, but I really really want to use the 970. I've done everything I can think of, short of reinstalling Sierra, or even Capitan. Do you guys have any suggestion?
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    CUDA has nothing to do with the picture being shown or not. You don't even need to install it in the first place.

    Yes you should have a startup chime.

    You may have a dead card. Does it work in another computer?
     
  3. JesterJJZ macrumors 68020

    JesterJJZ

    Joined:
    Jul 21, 2004
    #3
    Or it's not getting enough power. This was the case with my 980ti. Once I got an external PSU for it, all was well.
     
  4. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #4
    I'll test in the morning and report back... The fan does seem to be running when the computer start, and then stops after (I'm assuming) the OS loads.

    I've heard that the 980Ti is a very power hungry card. The 970 is a bit milder when it comes to power. Besides, other people have successfully used their 970 in their Mac Pro without any auxiliary PSU.

    Unrelated (maybe related): Is there any electrical difference between 2x 6-pin and 1x 6-pin and 1x 8-pin but the 8-pin is hooked to the 2nd 6 pin with a 6-8 pin adaptor? Could the original 2x 6-pins not provide enough power?
     
  5. devildcn macrumors newbie

    devildcn

    Joined:
    Jun 22, 2015
    #5
    Hey,
    I've got the same mac pro today from one customer and i have the same problem with EVGA GTX970 SC (6+6 pin).
    Sierra doesn't somehow save nvda_drv=1 key in boot args.
    I've also checked original 5770 + gtx750ti. Sierra boots, but gtx750ti is not detected correctly (only as monitor with no kext loaded).

    I've checked El Capitan and everything is working as it should.

    The only way atm I've managed to boot with gtx970 is next:
    boot in single user mode CMD+S (with black screen just wait a bit)
    hit enter
    type: sudo nvram nvda_drv=1
    hit enter and wait 2 sec
    type: exit
    hit enter and wait for logging screen

    If anyone know how to solve this strange bug, i'll be grateful to receive the solution.
     
  6. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
  7. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #7
    Yes, SIP is disabled. Would that matter?
     
  8. devildcn macrumors newbie

    devildcn

    Joined:
    Jun 22, 2015
  9. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #9
    UPDATE: I don't have a machine to test out the card. Is there any way i could diagnose it with my mac pro?

    i've also gathered some tidbits and potential solutions on the Internet, but is there any merits to them at all?
    • Reset PRAM (Would I do this with the 5770 or the 970 installed?)
    • Remove the CMOS battery beneath the card on the logic board (The clip holding down the battery is VERY stiff, any ideas?)
    I've already mentioned this, but the card seems to be running (fans are on at start up).
     
  10. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #10
    Reset PRAM will only make the card doesn't work, because it will reset the driver setting, and make the card run with the Apple driver, that means a no go.

    I think at least worth to try to instal an old OSX (e.g. Yosemite), and then do the same procedure to activate the 970. If that works, then it's purely MacOS's issue, but not the Mac's hardware or the card.
     
  11. Silencio macrumors 68020

    Silencio

    Joined:
    Jul 18, 2002
    Location:
    NYC
    #11
    The GTX 970 should be well within the power spec for a Mac Pro

    What port on the GTX 970 are you connecting your display to? I have a few GTX 970s here that I've installed in some of my Mac Pros, and I've found that not all the ports work. Try switching between the DVI port(s) and the various DisplayPort ports your card has.

    Also, do you have another Mac handy that you can use to screen share into your Mac Pro? You can try that to make sure the Nvidia driver is loaded and active.
     
  12. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #12
    OP,

    There is an NVRAM parameter that tells the computer to use the Nvidia web drivers instead of the Apple drivers:
    "nvda_drv=1". When you flip the switch in the Nvidia preference pane between Nvidia and Apple drivers, the preference pane should be flipping that NVRAM parameter on and off. Because you have a Maxwell card, it is absolutely critical that you run the web drivers, or you will get stuck in an endless boot loop and have a black screen. So that setting must be on.

    From Devildcn, it sounds like that parameter isn't actually being saved despite what the preference pane is showing you. So that may be what is happening.

    You can doublecheck at the command line whether or not that setting is stored by running this:
    sudo nvram -p

    That will list all of the parameters, and you should see "nvda_drv=1". If you don't, then for some reason the preference pane is unable to make that setting stick. You can set the setting yourself at the command line with the following:
    sudo nvram nvda_drv=1

    I have done this myself and noted that the actual nvram parameter setting does not always match what the preference pane claims.

    Don't do a PRAM reset. This clears out all of the nvram settings, including the one that you need to run the web drivers. Or rather, if you want to do a PRAM reset to get everything back to default, that's fine and maybe even a good idea. But just remember you'll have to set "nvda_drv=1" again afterward to ensure the web drivers are enabled, so you'll need to do all that with the 5770 in.

    There is potentially some merit there. The nvram parameter might require battery power to preserve its settings when there is no power. And you are removing power to swap cards. So it's possible that when you remove power, and if the battery is dead, that the "nvda_drv=1" is lost from NVRAM. That would cause exactly the symptoms you describe.

    You can test for this without replacing the battery:

    Boot up in the 5770, set the parameter manually as described above, doublecheck it with the -p to make sure the setting has stuck. Turn off the computer, remove power. Reconnect power, boot up and with -p check to see if the parameter has survived a reboot.
     
  13. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #13
    Are you able to get video when you boot in to the Recovery partition? If yes, you can launch Terminal and set nvda_drv=1 from there.
     
  14. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #14
    Hi guys,

    Thanks for the replies. I did a sudo nvram -p and it does show that "nvda_drv=1" (screenshot attached). The preference panel also confirms that the system is using web driver.

    I did a clean install of El Capitan, and the compatible web driver (346 something), just to make sure that I didn't screw up somewhere on the way. Still couldn't see any pictures on that set up either.

    As this point, could I consider my 970 dead? :(
    --- Post Merged, Oct 9, 2016 ---
    I connect my monitor to the HDMI port. Should I switch it to the displayport?

    I'm pretty sure that the web driver is loaded and active (checked it in terminal)
     

    Attached Files:

  15. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #15
    Not sure, but I'm starting to lean towards that. By trying ElCap you've verified you don't have the same Sierra problem as @devildcn in post 5. By trying a clean install you've eliminated any weird settings or third party as the software. You've also verified that the drivers are installed and selected.

    You could be certain by installing Windows (using your old card to get it installed), then switching for the 970 to see if it works in Windows. Or ask a friend if you can stuff the 970 in their PC temporarily to see if it works.
     
  16. Shamgar macrumors regular

    Joined:
    Jun 28, 2015
    #16
    It could be an issue with your power cables. The 6 pin power from the Mac Pro should be sufficient, but the GPU will not complete its start up unless the additional 2 pins detect ground.
     
  17. orph macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    UK
    #17
    it's worth trying display port (and all the outhere video out's from the card) in case one works.
    do you have a second mac might be worth booting with screen sharing turned on to see if you can remotely poke around to see if the card is detected by the macpro and if the display is detected.
     
  18. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #18
    UPDATE: I have a DP to HDMI and a new 6 to 8 pin power cable coming, just to make sure that there's no problem with power delivery or port malfunctions. I also plan on installing Windows to see if I could somehow make it work there.

    I have a MBP that I could potentially use to screen share. How exactly do I do that?
     
  19. orph macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    UK
    #19
    screen sharing

    system prefes -> sharing -> screen sharing (tick the box)

    both computers need to be on the same network, on your MBP open a folder and on the left side you shude see your macpro click on your macpro then click screen sharing

    https://support.apple.com/kb/PH21800?locale=en_US

    once you log in to yout macpro have a look in to about this mac & system report + check if the nvidia driver is on
     
  20. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #20
    More updates lol: I did screen sharing, and the driver was indeed on. I tried all the ports like someone suggested. Nothing. Nein. So I went ahead and submitted an RMA request. At this point, I think it's safe to assume that the card is dead. They authorized the RMA, and I'm shipping out the card today.
     
  21. orph macrumors 6502a

    Joined:
    Dec 12, 2005
    Location:
    UK
    #21
    cool, always good to have screen sharing on in-case you have a problem with a gtx9xx card (like security update brakes drivers so you need to login in to update the nvidia drivers then rebote to get display back)
     
  22. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #22
    Card came today. Funny thing though, I could use my main monitor just fine (an LG 29 inch ultrawide, plugged using a DP to HDMI cable), but whenever I tried to plug my second monitor (a very old Samsung) using a DVI to VGA cable, the Mac reboots and there's no picture coming out of neither screens. When I unplug the DVI, the mac reboots again and the main screen is back to normal.

    Any ideas?
     
  23. onixLeo macrumors newbie

    onixLeo

    Joined:
    Dec 29, 2016
    #23
    Hi ttminh1997 i was wondering if you resolve this thing.. im having exactly the same problem as you wrote in the first post.. i couldn't pass the black screen and boot sound loop after installing the exact gtx970 GPU, the drivers and selecting it from the menu bar..
    pls let me know if you find a solution..
     
  24. ttminh1997 thread starter macrumors newbie

    Joined:
    Oct 6, 2016
    #24
    Hi,

    If you follow my earlier replies, you'd see that I ended up RMAing the card and got a new one from EVGA. The new one worked flawlessly, so if all else fails for you, I'd suggest you try to RMA the card.
     

Share This Page