USB (2.0) Flash Key Drive Not appearing

Discussion in 'Macintosh Computers' started by AngryAngel, Nov 26, 2003.

  1. AngryAngel macrumors regular

    Jul 12, 2003
    A USB 2.0 (says its v.1 compatible) non-branded flash disk is not appearing on a rev. A clamshell iBook runnning 10.3.1. It doesn't appear in the disk uility list of connected drives (not just without a volume- it doesn't appear at all).

    It works fine on XP with USB 1.

    I have read everything I can find on USB flash drives, and I am going to try reformatting it on the PC, in case it has some form of passwording or some wierd format done at the manufacturers. Anyone had similar experiences/heard of any solutions?

  2. SilentPanda Moderator emeritus


    Oct 8, 2002
    The Bamboo Forest
    I know that this on brand that I bought my Dad for his birthday wouldn't work on his G5 because the USB key drive was switched to a locked position (physical thing on the unit). When we switched it to unlocked it worked just fine. It worked fine locked/unlocked in Windows though. So try that if your USB thing has a physical lock/unlock switch on it... otherwise... next message.
  3. Megaquad macrumors 6502a

    Jul 12, 2001
    It might need special drivers, what company is making them?
  4. AngryAngel thread starter macrumors regular

    Jul 12, 2003
    There is no physical locking mechanism on this one.

    It is a driverless model (i.e. should abide by the USB mass stroage spec). It is made by a non-brand: no web site or contact details, etc.

    It is wierd because it works fine driverless on XP, so it must be compatible with Microsoft's implimentation of the USB mass storage device spec. And it appears not to be the format of the volume, as the device doesn't even appear in Disk Utility (as other devices with unreadable volumes do).

    Thanks for the replies.
  5. jxyama macrumors 68040


    Apr 3, 2003
    i have an ext. HD with FW and USB2 ports.

    it was originally formatted in FAT32, but i reformatted in HFS+ because it was a little buggy on my PB.

    i can see it fine on my PB with FW but not with USB2. i *believe* there's not enough bus power via USB.

    XP can see the device via USB1 port, but can't read as it's in HFS+. it just says high speed USB device found and doesn't mount the disk.

    can you plug it in and run your system profiler to see what it says on the USB port?
  6. AngryAngel thread starter macrumors regular

    Jul 12, 2003
    Update: The disk mounts in OS 9- and works fine. Drive Setup (OS9) cannot format the disk because the drive is not supported.

    OS 10.3.1's Disk Utility cannot see the drive, while the Apple System Profiler can.

    I am reformatting to UFS on Windows XP, to see if this makes a difference.

    I've never heard of a situation where OS 9's standard mass storage drivers seem better than OS X's. I've had firewire drives appear on OS X when they need drivers for 9... anyway, I hope the UFS thing works, and if not I'll be hoping Apple adds support for this sub-set of USB drives. I'll also see if using it with my USB2 G5 with 10.3.1 makes a difference.
  7. Anarchy99 macrumors 6502a

    Dec 13, 2003
  8. happo macrumors newbie

    Nov 18, 2003
    I'm having problems with USB flash memories, too. Have one 64Mb Pretec i-Disk and one 64Mb Dell (came with my work laptop) USB (1.1) flash memory - both FAT-formatted.

    They work just fine (driverless) in OS9.2.2, OS X.1.5 (on G4, never had Jaguar), Win 2000 and XP, but Panther (10.3.0/.1/.2 on G5) just refuses to mount them. Disk Utility regonizes both and I can format them, but I need the FAT-format for Windoze compatibility.

    Pretec has driver on their web-page (here), but I've found no way to get the installer work. Dell has none as far as I know.

    Now I need to carry that evil Dell laptop with me all the time, instead of working on Mac at home. :(
  9. Nik_Doof macrumors regular

    Sep 15, 2003
    St Helens, UK
    I had this with a Transcend 64mb stick, turned out i had to use the Windows util to format it as a non protected partition. As by default it was password protected.
  10. Falleron macrumors 68000


    Nov 22, 2001
    Try the update to 10.3.2.

Share This Page