USB HDD only show up on one of Macs

Discussion in 'OS X El Capitan (10.11)' started by AppleHater, Nov 28, 2015.

  1. AppleHater macrumors 6502a

    Joined:
    Jun 9, 2010
    #1
    I have a WD USB hard drive that I've using with my MBP. Now, I connect it to my new iMac and I'm having all kinds of issues. First, I had to authenticate every time when I try to write to it or modify anything.

    I searched up internet to use sudo command to remove that authentication requirement. Instead, the drive stops showing up on the left panel of Finder, nor iMovie, nor Lightroom.

    I can access it fine from the desk top using the desktop icon, but it's not accessible other ways. What should I do to fix this? This is my main data drive and it'll be a pain in the butt if I have to reformat this...
     
  2. IHelpId10t5 macrumors 6502

    Joined:
    Nov 28, 2014
    #2
    Right-click the drive's icon, choose "Get Info", click the lock in the lower right and authenticate yourself, then enable the "Ignore ownership on this volume" check box.
     
  3. AppleHater thread starter macrumors 6502a

    Joined:
    Jun 9, 2010
    #3
    Problem is that that selection itself won't show up for this drive. Even on my MBP, that open is gone for the drive, although I have no other symptoms with it that have with the iMac.
     
  4. AppleHater thread starter macrumors 6502a

    Joined:
    Jun 9, 2010
    #4
    To add more, I can unmount it from Path Finder, but I get an error if I try to unmount it from the terminal. It asked me to use diskunmount.
     
  5. Rodan52 macrumors regular

    Rodan52

    Joined:
    Sep 21, 2013
    Location:
    Melbourne, Australia and Bali, Indonesia
    #5
    Have you tried repairing it in Disk Utility if it is visible?
     
  6. AppleHater thread starter macrumors 6502a

    Joined:
    Jun 9, 2010
    #6
    Thing is that verify or repair option doesn't even come up. If I choose it from the menu bar, the drive doesn't show up among choices.
     
  7. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #7
    So USB 3.
    Have you tried moving the drive farther away from the Mac before startup?
     

Share This Page