USB Peripherals not working. Possible causes ... ?

Blizzard

macrumors newbie
Original poster
Jun 5, 2002
3
0
I have a G3/300 Yosemite. Recently, I stopped getting a Zip Disk icon when I placed a Zip Disk in my Zip Drive. Then I noticed that whenever I used my VST Flopy Drive, no matter what disk I inserted, I would be told that the disk was unreadable and all attempts to initialize these disks failed. Finally, my Brother HL-1240 Laser printer gets a consistent -23 error asking me to "check printer."

Things to consider. I was running MacOS 8.5 up until a few weeks ago. I upgraded to 9 ... 9.1 and 9.2 so that I could test a trial of Illustrator 10. This may not be the problem, however. I have also been carting my machine back and forth to my office weekly.

Please help. This is creating huge problems for me.
 

Blizzard

macrumors newbie
Original poster
Jun 5, 2002
3
0
One down ...

Apparently, the Iomega Drive Update worked. (So far I've rebooted twice and stuck in disks without a problem.) However, my printer and my floppy drive are still not working after installing the most recent drivers.

Thanks. At least it's a step in the right direction.
 

mymemory

macrumors 68020
May 9, 2001
2,495
0
Miami
I would disable the floppy extensions and try the unit to see if it works. I have some peripherals that comes with extensions but the Mac run them with no problem. That is an extension problem. Try deleting the preferences too. That kind of problem should be in those places.
 

menoinjun

macrumors 6502a
Jul 7, 2001
567
0
Have you tried any firmware updates? That might help.

They should come on the OS 9 install disks.

-Pete
 

Blizzard

macrumors newbie
Original poster
Jun 5, 2002
3
0
SUCCESS!

Thanks. I did all of the above and I am up and running. I cleared out the old extensions. I reinstalled the firmware. Everything is working.

Thanks again, guys.