USB ports are dead on my MACBOOK? Woah, can you help?

Discussion in 'Mac Basics and Help' started by Haruhi, May 1, 2010.

  1. Haruhi macrumors regular

    Joined:
    Sep 19, 2008
    #1
    Both USB ports on my 2007 macbook are dead. They only work if I plug my iPod in.
    Other than this I have to turn the computer off and THEN plug stuff in and THEN turn it on again for it to even recognize stuff.
    USB devices often just keep saying connecting to computer or say theres an unknown error when connecting. (they sort of recognize they're plugged in but don't work)

    :apple:Has been going on for 2 years- and I am getting fed up! Please help :apple:
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Are you still under warranty?

    I'd try resetting the PRAM and SMC first.
     
  3. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
    #3
    Care to tell me what PRAM and SMC are? :D:D:D (sorry)
    My warranty ran out a while ago I believe.
     
  4. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #4
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
  6. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
    #6
    Wil this do anything to the madc itself? no files deleted?
     
  7. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #7
    Everything will remain the same, it just resets few things that may have caused your issue
     
  8. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #8
    It will clear certain volatile RAM on your Mac. Always have a backup regardless.
     
  9. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
  10. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #10
    Something I have seen like this has happen on a windows computer that I was trouble shooting and it turned out the drivers for the USB ports got corrupted The solution there was to deleted respective drivers and reinstall them.

    That would be my solution is find the USB drivers, deleted them then reinstall them.
     
  11. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
  12. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
    #12
    Resetted the pram and all is well again! Can now use my USB ports pdopey for 1st time in 2 yrs.
    Thanks guys :D
     

Share This Page