USB ports dead on Tibook. Help needed.

Discussion in 'Mac Help/Tips' started by Thirteenva, Nov 11, 2002.

  1. Thirteenva macrumors 6502a

    Jul 18, 2002
    Hi everyone. Last night my Tibook usb ports stopped working. The mouse(macally optical) stopped working and the optical sensor and light went off. I restarted and the mouse worked again, but very choppy with the light flickering. THen it went black.

    At first i thought it was just the mouse, i tried to other mice i have and neither worked. I hooked up my digital camera to the usb ports and OSX didn't see it. Now when i start up the tibook, the mouse lights and works for about a second(very choppy) then the optical sensor and light turn off and the usb ports are dead.

    My trackpad still works but i need the usb ports, i do graphics and need to use a mouse and usb add ons such as camera, scanner, printer. Please help

    I"m running a 500mhz rev A tibook. I have 10.2 installed. The computer has worked flawlessly since i got it over a year ago.
  2. BenderBot1138 macrumors 6502

    Oct 28, 2002
    USB Troubleshooting

    1) I assume your firmware is up to date.

    2) Run your Apple System Profiler (ASP) first and see what it says...if it doesn't see your USB devices, might be a job for an Apple Hardware Service Professional.

    3) On the otherhand, if ASP sees your USB devices, try holding down the shift key when you startup your Tibook.

    4) If your ASP sees your USB devices, and the shift key startup doesn't solve your problem, reinstall your software (check to see if there's an web update first for your macally optical mouse).

    Info from Apple Knowledge Base Document ID: 58033
  3. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    I'm 99% sure my firmware is up to date. I"ve had the mouse for about 8 months with no problems with it ever.

    The other mice i have including the one i had prior to this also do not work.

    None of my other peripheral USB devices are workign either.

    If i have to tear this thing apart and fix it myself i will. I really can't afford to spend $400 bucks to have apple fix it(no longer under warranty :( ) and i cant afford to be with out a computer for a few weeks.
  4. BenderBot1138 macrumors 6502

    Oct 28, 2002
    Your Apple System Profiler is in the following Directory...

    HD (your hardrive)-->Applications-->Utilities

    Does it see your USB Devices? (This seems like a stupid point to raise, but make sure your USB devices are properly plugged in if they are powered - I've done that sometimes too).
  5. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    Don't worry i know where ASP is ;), i forget to mention in the last post that i couldnt check ASP because i'm on my machine at work right now, i'm not on the laptop, i have no use for it with no mouse and periph. support, I will check as soon as i possibly can.

    My guess is that it will see the mouse at boot because the mouse is working at boot up but after using it for a minute maybe less it just dies.

    It doesn't sound silly to say check the connection, it was the first thing i did :) , But wasn't able to get any periph to work, i enven tried jiggling the usb cable with the mouse and/or pheripherals plugged in.

    This problem just came out of no where. Yesterday morning, i'm working in flash and photoshop, put the tibook to sleep. Wake it up later that evening and the mouse died after a minute of use. And the scenario described above ensued.

    I"m very grateful foryour help, Bender.

    My guess is that it won't see the device if i open ASP after the mouse dies. THe computer isn't seeing any thing at that point, but it will probably see it if i open it right after a reboot.

    Once i start it up and the usb port stops working it doesnt start iphoto with the camera plugged in (like it usually does), it doesnt launch disk copy when my cd-rw is plugged in(like it usually does), Its not doing anything. Damn thing just wants me to spend money i don't have..:mad:

    Oh i also tried booting from the jaguar cd to see if the problem persisted. It does, After less than a minute the mouse flickers and dies. I was hoping it was an OS X issue, i have the system on seperate partition from my work in case i have to do a quick erase and reinstall for any reason.
  6. FelixDerKater Contributor


    Apr 12, 2002
    Nirgendwo in Amerika
    Is your mouse connected through a hub? If so, what kind?
    Have you tried any other hardware on the USB port other than a mouse?
    Have you tried switching the mouse from USB 1 to USB 2?

    At one point one of the USB ports on my Ti was acting up. Sometimes it would stop working for a bit until you restarted, but that hasn't happened for a while now.
  7. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    Felix, yes i tried my camera, my cd-rw and three mice.(see post right above yours), I'm not using a usb hub. I've tried both usb ports, One seems liek it works better than the other but both will die after less than a minutes use.

    Everytime i reboot the mouse will light up i'll go to use the computer and the mouse will die in less than a minutes time.

    I'm baffled, I've never had a problem with the computer.
  8. BenderBot1138 macrumors 6502

    Oct 28, 2002
    Sounds more and more like hardware, but I'm still holding out hope your ASP will see your USB devices beyond the first few minutes.

    I didn't ask, but do you have more than one USB device hooked up to your USB port? Apple states that you shouldn't have more than one isyochronis (time-sensitive) high bandwidth USB device per USB. USB runs at 12 MB/s, and more than one of these USB devices hooked into it might be too much.

    Camera's and CD-R drives are definitely isochronous devices. Other questions I have include when did you install 10.2 - that's new (not on for the year you've had all running - meaning might be a software thing for your devices then). Also have you added anything else etc. Sometimes...

    Be sure to check back here after a day too, if all this fails, there are some pure gold experts that run and visit MacRumors that are bound to see all this and might have some more ideas.

  9. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    I did shutdown and pull the battery out for a few minutes.

    I have not used two usb devices during the toubleshoting of this problem because i assumed it would only aggravate the problem. I have in the past used both my mouse and camera, or mouse and scanner, or mouse and cd-rw with no problems. I always use my usb ports and this is the first problem i've had.

    Oh the mouse software, i didn't install any software for any of my mice under OS X. Not since os 9 have i used mouse software.

    I haven't made any changes to the computer in months. I have installed a larger hard drive but months ago, I installed jaguar when it was first released. So i can't think of anything new i've done to have caused this. The ti book hasn't been banged around, I've actually had it on my desk for two weeks.

    Only two things i can think of, I have been leaving it on sleep overnight and not shutting it down. (though i have done this in the past with no issues). And i've been using hte internet sharing to share the airport internet connection with a pc connected via ethernet which i have since unplugged to see if that fixed the problem. Other than that i can't think of anything that has been diffrent lately to have caused this.
  10. BenderBot1138 macrumors 6502

    Oct 28, 2002
    Hmmm.... are you using an external monitor? If you are, and connected one of your USB devices, especially if its isochronous, to your sleeping powerbook, that'll do it. In that case you probably had a working monitor, but no USB, but starting over should have some effect... hmmm

    Big question then is do you have an external monitor?
  11. FelixDerKater Contributor


    Apr 12, 2002
    Nirgendwo in Amerika
    Try booting off an OS 9 CD and see if it works for more than a minute while booted into 9.
  12. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    Bender - no external monitor hooked up to the powerbook.

    Felix - I don't have an os 9 cd handy right now, I will boot off the tibooks original software install cd when i get home today and see if the mouse works.

    Any other thoughts?

    Someone told me if i got it repaired they'd replace the whole main board, andit would be about 400-500 dollars.

    I'm fearful this is a hardware issue :(, i really don't want to spend 500 to repair it but i also can't go buy the a new ghz tibook to replace it as much as i would love to...:D
  13. FelixDerKater Contributor


    Apr 12, 2002
    Nirgendwo in Amerika
    Yeah, the original install CD should boot to 9.
  14. BenderBot1138 macrumors 6502

    Oct 28, 2002
    Hubbub about USB

    Cool problem... also try VersionTracker, or other third-party software...

    But then again, you say same problem with your camera too and CD ... and no HUB... hmmm

    Coach to players on a losing team at half-time... "ARE YOU IDIOTS ON DRUGS?"

    Players (in unison): NOOOOOOO

    Coach.... "Well START"

    Get a HUB at WalMart for under 20 bucks and if it doesn't work, return. Try for a Powered HUB of course; Your USB port might not be giving enough love to your devices under your new system.
  15. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    This is so odd, doesn't seem to matter if i boot from a cd or not.

    I erased my system partition and did a fresh install of jaguar. The problem still persists.

    I noticed on othe thing. If i use the mouse on one usb port till it stops working, then i plug it into the other usb port it will work for a few more mins, then the usb will die and i'll have to restart.

    I'm baffled. i don't know what else to try.
  16. Thirteenva thread starter macrumors 6502a

    Jul 18, 2002
    Think i solved it.

    Something is wrong with the macally mouse. Maybe a short or something.

    I restarted last night, zapped the pram, and used an old mouse and some other usb periphs with no problems. As soon as i plug the macally mouse in the optical sensor flickers and the port goes dead.

    I'm thinking there is a short in the macally mouse. And the computer shuts down the port to prevent damage (once the port goes dead i have to restart to use it again).

    I'm pretty sure this is the case. I restarted again and zapped the pram and used my other mouse for about an hour with no problems.

    It's odd, i've had the macally for about 8 months. With no issues. I actually liked it alot. Oh well, I'm hoping the mouse was the issue i'd much rather buy a mouse than pay for the repair to the tibook. I just hope it didnt do any damage to the usb ports or the main board.....

    anyone use that new kensington studio mouse designed only for macs, good looking mouse, and the scroll sensor instead of a scroll wheel is pretty cool...

    and THANK YOU everybody for all your help.:)

Share This Page