USB stick drive not showing up on desktop

Discussion in 'Macintosh Computers' started by karambos, Sep 15, 2004.

  1. karambos macrumors newbie

    Sep 1, 2004
    Mac G4 MDD, dual 1GHz, 1,25GB RAM, OS10.2.8

    I tried connecting a USB/mp3 player stick drive thing to the USB port on my keyboard today. I assume a drive icon normally appears on the desktop which didn't happen. So I checked in the System Profiler and it recognised the drive, where it was attached, the name of the retailer, drive number, memory etc. The system Profiler seemed to know quite a lot about my drive. Sadly, I couldn't access it, though.

    Am I looking in the wrong place under OS10.2.8? It worked fine under Mac OS9 - I used to just attached it the the keyboard usb port and a drive icon appeared. The USB stick thingy came with a CD but only contained WIN98 drivers. Couldn't find a webpage for them but assume there is no mac support.

    I'd be grateful for any ideas/tips/help
  2. Toe macrumors 65816


    Mar 25, 2002
    Can Disk Utility see it? If so, can it Mount it? If not Mount, then can it Erase it?
  3. Gee macrumors 65816

    Feb 27, 2004
    London, UK
    Same thing happened to me recently, but the drive did appear when plugged into one of the spare USB ports on the back of the computer....

    Weird but true
  4. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Some USB drives need the power that comes from plugging into a port on the machine rather than the keyboard port...
  5. karambos thread starter macrumors newbie

    Sep 1, 2004
    I've tried a number of things now and had no success. I connected the USB stick to the back of the mac (in a USB port directly) and THEN booted the computer. I could see it in the Apple System Profiler but nowhere else. I tried booting first. Ditto. Tried same thing in all USB ports (powered hub, keyboard, comuter itself). Same each time. In fact, it shows up in the Apple System Profiler no matter which USB port I connect it to - the computer direct, the keyboard or my powered hub.

    The option to turn the display of volumes on the desktop is turned ON.

    The drive itself is switched ON.

    The drive can't have expired, it's brand new.

    If I open Disk Utility I see absolutely nada. No hard drives, no usb drives. Zilch. It just says "Select a disk or volume" but there is nothing in the list, not even my hard drives.

    I don't want to have to open the USB stick in i-Tunes because I will be transporting data around with it, not just music.

    When I pull the USB stick OUT again I always get this message: "You have attached a drive that is not compatible with OSX. To continue with drive inserted click ignore".

    Incidentally, I can access the drive under windoze and I can save things on it and delete them. I can also reformat it. The choices are FAT, NTFS or FAT32. Would reformatting ithe drive on a windoze machine help matters?

    I am, as always, grateful for any help on this issue.
  6. homerjward macrumors 68030


    May 11, 2004
    fig tree
    IIRC Macs can read/write FAT32 disks so formatting it to that might help?
  7. karambos thread starter macrumors newbie

    Sep 1, 2004
    the story continued..........

    My hard drives are showing up in Disk Utility.

    I now have the following peripheral drives attached:

    i) A LaCie 3.5" floppy drive attached to the computer via the USB port at the back
    ii) a Iomega 1GB JAZ drive attached to the computer via a Adaptec SCSI connect 2906 PCI card
    iii) this pesky flash drive attached to the computer via powered hub and formatted to FAT32.

    I put a disk in the floppy and the JAZ and attached the flash drive. None showed up on the desktop. However, in the SYSTEM PROFILER the floppy and the flash drive show up but not the JAZ.

    I booted to install disk and opened DISK UTILITY. After a while, it saw the JAZ drive (and the inserted disk) so I clicked VERIFY DISK. After 5-6 minutes of spinning beach ball cursor, it verified the JAZ drive in about 2 seconds and suddenly my flash drive appeared. Normally it displays a drive size and a drive name. With the flash it just displayed the drive size hence DRIVE PERMISSIONS is not active. I clicked on the flash drive icon and got spinning beach ball cursor for about 20 minutes. This is not an exaggeration. I went to the PARTITION tab and all the clickable items were inactive and at the bottom it said "cannot initialise a read only disk"

    I restarted the computer and still none of them showed up on the desktop

    QUESTION 1: How do I initialise
    a)the flash drive
    b)the floppy

    QUESTION 2: How do I get any of them to appear on the desktop?
  8. Blue Velvet Moderator emeritus

    Jul 4, 2004
    We use USB drives all day at work (our highly-sophisticated and speedy way of moving data to & from our PCs – thanks to the IT team who won't let us network our new dual 2.5 G5s to their network).

    Some USB drives are temperamental and inconsistent with Panther, but one thing I found that definitely helped was reformatting the drive using the Erase option with Disk Utility as MS-DOS. No probs with any of them after that. Drives that once refused to mount in sidebars & desktops suddenly became good again...

    Doing something similar on a PC running Win 2000 just caused more probs and rendered some drives forever useless on the Macs.

    We're using 10.3.4 and although 10.3.5 is supposed to improve certain USB probs there have been other reported problems with this update. You could try downloading the updater from Apple – it may help.

    Oh, have just noticed you're running 10.2... Panther is worth every penny, it may seem perverse to encourage you to spend more money but the snappiness of the OS, greater reliability, and additional features make it worth it. When booting from my 10.2 backup drive, it feels horrible and clunky.
  9. karambos thread starter macrumors newbie

    Sep 1, 2004
    not sure I follow. This is an action you performed on a Mac? Or on a PC?
  10. Blue Velvet Moderator emeritus

    Jul 4, 2004
    If I remember rightly (it WAS late on a Fri afternoon) it came up as an option in Disk Utility for certain USB drives on my dual 2.5 G5 running 10.3.4.

    It could have said FAT32 but I'm sure it said MS-DOS. Anyway, clicked it and the drives immediately mounted and started behaving themselves...

    Ones we tried formatting using Win2000 wouldn't work on the Macs.

Share This Page