Use of Cydia pacakge to enable / install tethering 3GS 3G 3.1.2fw

Discussion in 'Jailbreaks and iOS Hacks' started by B737, Oct 19, 2009.

  1. B737 macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #1
    Has anyone installed the recently added the package in cydia from sinful enables tethering for 3GS?

    i looked through the thread on their forum its scattered with tons of different topics, not clear to follow..

    from the looks of it, you install the cydia package, reset network settings, and tethering is enabled/available.

    looks like you also may have to input network settings as well after the initial post install reboot.

    anyone tried this yet via cydia?
     
  2. bruinsrme macrumors 601

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    repo ifoneguide
    name: tethering patch 3GS

    works like a champ
    email, internet, sms, mms all still work
     

    Attached Files:

  3. junebug1 macrumors regular

    Joined:
    Jan 24, 2007
    #3
    absolutely did not work for me...ended up having to do a complete restore. i first installed the repo listed then downloaded the package. reset network settings. reboot. nothing was there. deleted the package and phone was stuck at boot. maybe there will be a more reliable package out later today.
     
  4. antsh macrumors member

    Joined:
    Oct 9, 2007
    Location:
    San Francisco
    #4
    It works!

    This app worked for me! I downloaded the app, and at first, no tethering option showed up, even after network reset and proper restart of the phone. I then read up on it a little bit and found the guide at http://thebeatmix.blogspot.com/2009/10/enable-tethering-on-iphone-312-only-3g.html. Noticed that it said to download the profile from http://help.benm.at if the tethering option wasn't showing up. Downloaded the profile, restarted the phone, and the option was there. Works for me using both bluetooth and USB.

    I am on AT&T by the way. iPhone 3GS, 3.1.2 w/blackra1n, carrier 5.6.

    P.S. This was posted using bluetooth tethering on my 3GS.
     
  5. richm322 macrumors newbie

    Joined:
    Oct 21, 2009
    #5
    could you tell me how you did the restore? I just downloaded the same package and I cant even get the phone to bring up iTunes. Please help me!! :(
     
  6. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #6
    ifoneguide... dot wat? .com? .org?
     
  7. himni macrumors regular

    Joined:
    Sep 24, 2009
    #7
    ifoneguide.nl
    You can find it in the repositories. It is just called iFoneguide.
     
  8. koollectablz macrumors 6502

    Joined:
    Feb 1, 2009
    #8
    Well this works like a dream on my 16gb 3g JB 3.1.2 O2-UK contract iphone.

    Installed the 3g specific package through cydia from cydia.ifoneguide.nl then rebooted phone then reinstalled the benm profile, reset network settings and bam -works.

    Everything else like SMS, phone, safari, vvm works as well.

    Kool.
     
  9. junebug1 macrumors regular

    Joined:
    Jan 24, 2007
    #9
    Okay so after I installed the package from Cydia and proceeded to follow the appropriate steps as listed to no avail I decided to remove the package which I am assuming you have done as well and then got stuck in the endless boot logo. I literally sat there for about 2 hours holding down the home and power buttons trying to get the iPhone to go through a full restart but nothing would work. I ended up getting the iPhone into DFU mode but when I tried to restore to the custom firmware from PwnageTool I got the classic 16XX error. So I kept at the home and power restarts and finally my iPhone popped up in iTunes but the iPhone was still at the boot logo...either way iTunes let me restore with the custom firmware and all was well. Ended up using the Cydia package from SinFul repo and that worked flawlessly.
     
  10. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #10
    This is pretty much very accurate. Resetting network settings was a MUST for me to get it to work.

    Thanks to all the posters on the thread and the ifoneguide patch!
     
  11. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #11
    Doesn't work. Tried, reseting network settings and patch. No go.

    Edit - Got it working. However, my MacBook can't connect via BlueTooth to my iPhone 3GS. I can use USB tethering, but so far have been unsuccessful at a BlueTooth tether. MacBook sends the code, but my iPhone never displays it, neither does it display my MacBook under devices.

    Edit 2 - Got Bluetooth tethering working. Everything is running as it should now. For a moment I thought my Bluetooth chip had died and I had to go to Apple for a new one...
     
  12. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #12
    How did you set this up. I can pair my phone to my MBP but don't know what to do after this. My USB tethering works fine btw.
     
  13. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #13
    Once they are paired you are almost done. Just enable Internet Tethering in Network settings.

    Then in your Mac go to Bluetooth, select your device and click connect. You will connect and Internet data should start coming in. Also, your phone will now read Internet Tethering and the bar should be blue.
     
  14. B737 thread starter macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #14
    heres what i did...

    i just got around to doing this myself, it ended up being a simple two steps...
    on my 3GS 3.1.2 backra1n device..

    sinfuliphonerepo has "enable tethering for 3gs' package. install that, reboot
    reset network settings
    THEN go to http://tinyurl.com/yhgw4c6 (from your phone)
    install, reset network settings, reboot (automatic)

    now it works!


    ps...on my g/f stock 3G with 3.0fw i just went to the link on her phone and installed, one step it works as well.
     
  15. digitalfx macrumors 6502a

    digitalfx

    Joined:
    Jul 18, 2007
    #15
    Ive tried all these steps and keep getting:

    Ethernet Adaptor (en8) has a self-assigned IP address and will not be able to connect to the Internet.
     
  16. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #16
    Same for me. Had to restore as phone went into endless reboot loop. :mad:
     
  17. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #17
    I did the sinfuliphone tether on my 3GS 3.1.2. Works like a champ.


    Edit: I just did it again on my brothers 3GS. Worked flawlessly.

    Here's a mini guide:
    -Cydia > Manage > Sources > Edit > Add > http://sinfuliphonerepo.com
    -Sinful iPhone Repo > Enable Tethering for 3GS (or 3G) > Install
    -It'll ask you to reboot your Phone. It takes a little longer than usual to boot up.
    -You should now be able to tether under Settings > General > Network > Internet Tethering
    -If you don't see Internet Tethering go to Settings > General > Reset > Reset Network Settings.
     
  18. jayeskreezy macrumors 65816

    Joined:
    Mar 3, 2005
    #18
    yeah the sinful repo was easier....I had to reboot and respring though before it would work
     
  19. Jumpie macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #19
    I had this working last week then when I had iTunes open and tried to tether, I lost the tether. Now, after I've followed these intructions, my tether button is there, but I don't get the blue internet tether. Any ideas how to fix?
     
  20. TeamDNA macrumors 6502

    Joined:
    Sep 7, 2009
    #20
    it does not work for 3G.. tried it on 2 3G's ...restored both and followed exact instructions..

    then i do it on my 3GS like 5 times..NO problems at all... and you cant get rid of the internet tethering blue...GET USED TO IT ..its not a big deal
     
  21. biw999 macrumors member

    Joined:
    Apr 23, 2009
    #21
    This does work on the 3G no problem. I have a 16GB 3G that I just enabled tethering on and am currently typing this message via a tethered connection.


    All I did was:

    *Open Cydia
    *Click the "search" tab
    *Search for keyword "tether"
    *Look at results and find the Tether patch for 3G by ifoneguide
    *Install tether patch
    *Go to http://m.peacefulinsanity.com/Tether.mobileconfig on your iPhone browser and the profile
    *Hold the sleep button until your iPhone prompts you to slide to turn it off
    *Turn iPhone back on
    *Go to settings
    *Go to general
    *Go to reset
    *Click on "Reset network settings"
    *Confirm you want to reset network settings(press the red button)
    *The iPhone should reboot, upon start up, you should have the tethering option in settings>general>network.

    That's as specific as I can get and that is EXACTLY what I did and I had ZERO issues.

    Specs: 16GB Black iPhone 3G running 3.1.2 on ATT carrier file 5.6. Blackra1n installed (obviously).
     
  22. Jumpie macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #22
    Besides not being able to tether using USB, I've been having one other problem...

    Settings>General>Network>Cellular Data Network
    It shows APN as phone like it's supposed to. However, my phone will time out trying to connect to the internet. So, I have to go back, retype phone in settings, and then all is well.

    Anyone have any ideas?

    I used the appleguru tether.
     
  23. Jumpie macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #23
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_2 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7D11 Safari/528.16)

    I can tether CIA Bluetooth nit not via USB. Do I need to delete the iPhone under network on the mac and try and to re-add it? Even though I show the phone I there now, it doesn't show as connected.
     
  24. Zathu macrumors regular

    Zathu

    Joined:
    Nov 16, 2006
    Location:
    Maryland
    #24
    I was able to install the package, reset network settings, and install the help.benm.at file and now tethering works.

    The only issue is that now instead of saying AT&T in the top bar it just says "Searching...", although I can still receive calls.

    [EDIT] Solution for me was to turn on and off airplane mode.
     

Share This Page