used to connect to my WiFi but now can't

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mmorlan62, Feb 4, 2010.

  1. mmorlan62 macrumors newbie

    Joined:
    Feb 4, 2010
    #1
    Hi all,

    I did some Googling and, after reading older threads, decided it was time to post here about my problem. Neither my iPhone 3GS or my girlfriend's 3G will connect to our Buffalo WZR2-G300N router. Symptoms:

    • Configuration: cable modem <--> Linksys RV02 <--> WZR2-G300N
    • RV02 provides DHCP from 10.10.11.1. DHCP range 10.10.11.100-149. Using latest firmware.
    • WZR2-G300N is access-point only mode at 10.10.11.3. It points clients to the RV02 for gateway. Using latest firmware.
    • There are some fixed address, wired clients from 10.10.11.5-15 (printer, desktop PC's)
    • Three PC laptops connect just fine with WiFi DHCP.
    • I can connect the 3GS to a neighbor's unprotected WiFi and public WiFi points without a problem.
    • I used to connect my former 3G without issue. My gal's 3G doesn't connect now either.
    • There had been no changes to the WiFi point before I started struggling with this.
    • I have tried every conceivable combination of secured, unsecured, DHCP, static, etc. No luck.
    • I've reset the WiFi to factory default multiple times. I receive a momentary WiFi "fan" on the iPhone then lose it.
    • The 3GS consistently "connects" after considerable delay with the following "DHCP":

      IP Addr: 169.254.168.187
      Sub Mask: 255.255.0.0
      Router: blank
      DNS: blank

      Pinging the above IP address results in no returns.

    • The correct settings should be;

      IP Addr: 10.10.11.xxx
      Sub Mask: 255.255.255.0
      Router: 10.10.11.1
      DNS: 24.93.41.127 && 24.93.41.128
      (everything else has these.)

    • I never get the WiFi "fan" icon.
    • I've tried iPhone network reset and even a complete restore to default state with the guidance of Apple support.
    • A network ping snoop with Angry IP Scanner does not reveal any unexpected IP clients from 10.10.11.1-254.

    What am I missing? Did an iPhone OS update break this?

    Thanks for any thoughts.

    Michael
     
  2. mmorlan62 thread starter macrumors newbie

    Joined:
    Feb 4, 2010
    #2
    Well, no help from the forum but I continued to hammer at it until I simply bought another WiFi router (d-Link DIR-601.) Now everything is fine.

    M
     

Share This Page