User Agreement Policy Appear Before Login in Mac OS X Lion

Discussion in 'MacBook Pro' started by waheb09, Oct 20, 2013.

  1. waheb09 macrumors newbie

    Joined:
    Oct 20, 2013
    #1
    Hello everyone, I need a little help in here, please,
    I recently bought a used MacBook Pro 15 inch Retina, with OS X 10.7.5 Lion (I found it strange that a mid2012 retina came with OS X Lion):confused: anyway, every time I login, a window appears with user agreement policy and there is two buttons at the end, one it says "Reject" and the other one says "Accept" and I have to accept so I can log in otherwise I'll go back to the login screen where I must enter my username and password again.
    well I've been looking on the net trying to find a solution and I actually find out that you can create this banner message under OS X Lion by creation a simple rtf document then copy and paste it to /Library/Security/, so i went to that directory and there was nothing there except two folders the first one named "SecurityAgentPlugins" and the second one which is empty "TrueSettings" [had my hidden files shown and I also checked its size and it's 0 KB].
    well, is there anyway to remove this thing and back to normal?
    I'm afraid if I do a clean install my MacBook will go locked or EFI locked or what ever and I wont be able to use it again ?

    PS: I'm the only Administrator user with no guest

    please any kind of help would be much appreciated.
     
  2. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #2
    The original retinas were released with Lion installed. Mountain Lion was not released until some weeks later. So while it is uncommon, it's not unheard of, and it seems the original owner never upgraded.

    Secondly, the UELA was already agreed to when the computer was turned on and set up for the first time out of the box. I'd recommend backing up all of your information, then booting into the recovery partition and reinstalling OS X. If you don't wipe the HDD, all of your information should stay intact, but you will have a new copy of the OS and have gotten rid of any weird settings like you're running into. Your computer will not be "locked."

    The "EFI lock" you're referring to is a firmware password, which has to be manually set and will not get activated simply by reinstalling the OS.
     
  3. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #3
    thank you so much for clarifying things to me, but I'm sorry I didn't understand what's the EULA means ??

    I red something on the net the other day that some people wiped up their hard drives and did a fresh install from the crash but they ended up by an icon of a file with a question mark on it ???

    I don't care about my informations, I have tons of copies all around at work, home, so if it's safe to do a clean install it would be awesome.

    have a silly question too: could this message be stored in something other than the SSD ??? like in the EFI for example ??
    it does lock much more sophisticated than those you can create by a simple RTF document and store it on Library/Security/

    ps: have no contact with the seller anymore, he went back to UK, so if I screw up ... you know I'll probably shoot my self.


    thanks again.
     
  4. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #4
    Odd. Who was the original owner? This sort of setup implies it came from a business or school or organization, who would have likely removed the EFI lock before selling it. Just bringing up the possibility that the machine might be hot.
     
  5. Scott7975 macrumors 6502

    Joined:
    Oct 18, 2013
    #5
    EULA stands for End User License Agreement. Its basically legal mumbo jumbo that companies make you agree to before using their products. Its common in all software to cover their ass, so you cant sue them.

    Why it pops up every time for you, I don't know. Im not familiar with Macs but it must be that the computer doesn't remember you agreed to it. Like a bug in the software.
     
  6. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #6
    Thanks for mentioning that, and that's what the guy said, they gave it to him at work but "as he said" "he payed for it a small amount each month" and "he doesn't even use it, he just took it because it looked a nice deal at that time" and "he is a pc user, so why not selling it"

    I don't know if this informations does help but since you brought it up, hope you give me your opinion.
    Hot !! I don't think he would do such a thing, he looked really confidant and nice guy.
     
  7. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #7
    Thanks, I really appreciate it, but I don't think it's a bug, its there every time cause some one wants it to be there every time, so it's intended to show up every time I try to login, it appears before the username and password field appear and I must agree before I can enter them, anyway I now know what does it mean EULA thanks to you body.
     
  8. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #8
    Click on System Preferences > Users and Groups then select your username. Make sure it is an administrative account.

    Select Login Options ( click on the lock if necessary )

    Where it says "Automatic Login" select your username from the drop down list.

    It will ask for your log in password.

    Close System Preferences.

    Restart your Computer.

    Watch to see if the EULA pops up first or if you are automatically logged in without the EULA appearing.

    If it allows you to automatically log in it is not an EFI problem. It might be a bug that floated around certain builds of Lion a long time ago.


    Also if you could. Please post the version ( build number ) of OSX.
     
  9. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #9

    thanks bro, I did exactly what you told me, now I just don't have the login fields for the username and the password, it's just the EULA then after I click accept it just login to my account (I mean straight to the desktop)

    my system version is : Mac OS X 10.7.5 (11G63)
    Darwin 11.4.2
     
  10. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #10
    The only thing I can think of is either there is an EULA built into the EFI or you just need to re-install the OS..

    With that year Mac I don't understand why it doesn't have at least 10.8 on it.
     
  11. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #11
    Thank you for giving me some of your time and trying to help me, well I also find it strang that it has lion instead of mountain lion, but Sir Durkkin has explained that to me earlier in this tread that the original rMBP were shipped with lion, so that's the end of it, anyway I have some thing in mind I'll try it up tomorrow and see what will give me. I'll let you know about it. Thanks again.
     
  12. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #12
    Not saying it's so, but most drug dealers are really confidant and nice (especially when you're buying their product ;)).
     
  13. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #13
    Thanks my friend, I don't know him that well to be absolutely sure but he looked a hard worker fella wearing nice clothes and acting nice, anyway there's no way back for me now or is there ??
     
  14. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #14
    If you think there is a real possibility it's stolen and you're inclined to find the right owner, Apple can look up who it is registered to based off the serial number, but that's the closest you can get. Goods change hands, so even the registration (if there is one) has a fair chance of not being the guy you bought it from. If I were you, I wouldn't worry about the possibility of it being stolen and give the guy the benefit of the doubt. No need to worry over what most likely is not a realistic scenario.

    As for your original question, could you post a picture of the login dialogue that comes up? Also, are there any applications on there that stick out? I'm starting to think the computer might have something like Deep Freeze or is an administered computer like a business or school would have like goMac had earlier suggested.
     
  15. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #15
    Hello everyone, have some updates, I had an idea so here is what I did :

    I used my friends MacBook pro 15 inch 2012 (not retina) I hooked up a 500 GB hard drive to it through USB and performed a clean install of OS X mountain lion on it, then I took it off and hooked it up to my retina through USB, entered boot menu and booted from it, and guess what ! it did boot up normally with no problem and no EULA message :cool:
    so thats leave me with two conclusions, either the EULA message is built into the OS X it self (like some kind of a modified copy for the company) or it is some where and some how stored in the SSD.

    anyway, from the boot menu I noticed a suspicious partition with 1,27 GB mounted and it belongs to the original SSD named "image disk", so here is what I tried:
    I created an 8GB thumb drive with OS X mountain lion install.dmg using "lion disk maker" and booted from it, under disk utilities I tried to erase, format, unmount that 1,27 GB partition but everything was greyed out had no access to it :confused:

    so I'm thinking about removing the SSD out of the MacBook and see what I can do under linux or windows (still a theory) what do you think guys ?
     
  16. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #16
    Did you try to just repartition the SSD into one partition?
     
  17. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #17
    sorry I had to block out some words for privacy reasons in case the guy were honest.
     

    Attached Files:

  18. waheb09 thread starter macrumors newbie

    Joined:
    Oct 20, 2013
    #18
    well if I try to do any of these that means I take the risk and format the entire SSD and do a fresh install but the results are still unclear till now, I may not be able to boot it up again for ever.
     

Share This Page