Using Apple Music on Amazon Echo Dot - Getting it as default in the UK

digitaldave

macrumors regular
Original poster
Apr 6, 2006
127
9
I'm in the UK and have recently got an Amazon Echo Dot, and have setup up my Apple Music account to play through it. However, the instructions on Apple's Page state that if you set Apple Music as your default music service then you should be able to get it to play music without having to add '...from Apple Music' every time. I have set Apple Music as my default, but every time I tell it to play something (without using '...from Apple Music'), it says it's playing from Amazon Music instead. The connection to my Apple Music account works, because if I explicitly tell it to play from Apple Music, it says that's where it's playing from.

Has anyone else managed to get it working correctly? If so, what did you do?

Thanks.
 

Bazooka-joe

macrumors 68040
Mar 12, 2012
3,098
1,386
Swindon, England
I'm in the UK and have recently got an Amazon Echo Dot, and have setup up my Apple Music account to play through it. However, the instructions on Apple's Page state that if you set Apple Music as your default music service then you should be able to get it to play music without having to add '...from Apple Music' every time. I have set Apple Music as my default, but every time I tell it to play something (without using '...from Apple Music'), it says it's playing from Amazon Music instead. The connection to my Apple Music account works, because if I explicitly tell it to play from Apple Music, it says that's where it's playing from.

Has anyone else managed to get it working correctly? If so, what did you do?

Thanks.
I have been using it for months and it works really well. I just say stuff such as "Alexa, play my cocktail playlist" and it plays it from Apple music with no issues. However, when I tried tonight, Alexa said that I needed to link my account. I checked the Alexa app and it said it was linked. So I unlinked it and relinked it and it worked fine.
Interestingly, the instructions in the Alexa app says that you must say "Play ************ from Apple Music" which isn't true.
Anyway, disable the link in the Alexa app and relink and you should be able to play Apple music with having to say "from Apple Music"
 

digitaldave

macrumors regular
Original poster
Apr 6, 2006
127
9
I managed to solve it using the good old ‘switch it off and on again’ trick :)