Using iMessage on iPhone 4S overseas

Discussion in 'iPhone' started by lightweight, Jun 13, 2013.

  1. lightweight macrumors newbie

    Joined:
    Mar 25, 2013
    #1
    I just arrived in Hong Kong and I brought my Verizon iPhone 4S with me. I had Verizon unlock it for global use before I left.

    Anyways, I just bought a SIM card so now I have service, but I'm a little confused as to how to use iMessage on this. When I open up my messages app, many of the threads have lost their contact titles so I don't know who I'm texting (some of them still have their contacts associated).

    Also, looking in settings, my receiving number changed to my Hong Kong number. Does this mean people can't iMessage my US number anymore? How do I use iMessage to reach them?

    And how can I use my Mac for iMessage as well?

    I've never brought a phone with me overseas so all this help will be appreciated.
     
  2. DipDog3 macrumors 65816

    DipDog3

    Joined:
    Sep 20, 2002
    #2
    Your iMessages should also be tied to your iCloud email account.
    Look at your settings under:
    Settings > Messages > Send & Receive
     
  3. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #3
    Your contacts now come in unrecognized, possibly, because they're now sending you iMessages from their Apple ID and NOT from their phone number now. I think, and please correct me if I'm mistaken, that since you're no longer using the Apple server in the US you'll get this issue.
    You might have to verify who each message is from, then merely add that to their contact. From that point on, you should be golden.


    As DipDog said, go into your iMessage settings under "Send & Receive" and make sure you have your number, apple id, etc. is checked.
     

Share This Page