Usually hidden system folders like cores/sbin/usr/var/private/etc showing in finder

Discussion in 'macOS' started by ncdasa, May 12, 2009.

  1. ncdasa macrumors member

    Joined:
    May 11, 2009
    #1
    Recently i noticed that some of the Leopard OS system folders that are supposed to remain hidden i.e cores/sbin/usr/var/private/tmp/etc have shown up in the finder in the local HD.

    I cant remember when it started but recently i have reinstalled Leopard and installed Parallels. Maybe these things are unrelated but i thought i would mention it.


    If anyone knows whats up and how to hide them again please let me know.
    :apple:
     
  2. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
  3. mc3s macrumors member

    Joined:
    Apr 14, 2008
    #3
    Copy and paste this into terminal.


    defaults write com.apple.finder AppleShowAllFiles FALSE
    killall Finder
     
  4. ncdasa thread starter macrumors member

    Joined:
    May 11, 2009
    #4
    thanks for the suggestions, but unfortunately neither worked for me. I just saw the other day my friend had the same thing in his mac and he didnt notice it either until i asked him how to fix mine. Anyway I imagine that this problem may have happened to a few people so hopefully there is a few more suggestions and feedback that can be posted about this.

    It doesnt really effect the overall performance in anyway, its just hectic to look at. And also i guess it is not so safe to have all those system files exposed out in the open for someone who doesnt know what they are doing to accidentally fiddle with.

    Previously I foolishly deleted a strange folder i had never seen before named 'usr' from the finder and the whole system immediately committed suicide!!! :D
    I had to reinstall Leopard through target mode etc. I know it was a stupid mistake but it just goes to show my level of computer knowledge.
     
  5. angemon89 macrumors 68000

    angemon89

    Joined:
    Feb 5, 2008
    Location:
    The place where Apple designs stuff
    #5
    defaults write com.apple.finder AppleShowAllFiles -bool false; killall Finder


    Paste that entire line in terminal. They SHOULD disappear.
     
  6. ncdasa thread starter macrumors member

    Joined:
    May 11, 2009
    #6
    i dont know whats wrong but it still isnt working for me. It seems simple, just paste in the terminal and press enter , but i still have the problem. Anyway i guess i will just leave the files alone an ignore them, for the time being at least. Its not a big deal.

    Thanks anyway for all the suggestions, you can keep em coming though if there are anymore .
     
  7. lars666 macrumors 6502a

    Joined:
    Jul 13, 2008
    #7
    The exact thing happened to me today - after re-installing my Time Machine backup, the hidden "private" folder is visible. The mentioned Terminal lines don't work. Any other idea to make this folder hidden again??
     
  8. Wowzera macrumors 6502a

    Joined:
    Oct 14, 2008
    Location:
    Brazil
    #8
    Try it:

    Code:
    sudo defaults write com.apple.finder AppleShowAllFiles -bool false; killall Finder
    
    It will ask for your password, type it and press return.



    OR



    then delete /Library/Caches/com.apple.LaunchServices* (2 files) and reboot.

    Make sure you have Developer tools installed. If not, you can download it from Apple or install it from your Mac OS X Leopard disk.


    OR


    re-install Leopard again, it will overwrite the files and the issue may disappear.


    There's also some other options, if you these don't work.
     
  9. ncdasa thread starter macrumors member

    Joined:
    May 11, 2009
    #9
    Thanks wowzera,

    That 2nd one worked!!

    I had to install the Xcode Tools package from my Leopard installer disk because the individual Developer Tools installer wasnt working. So i ended up having to use more disk space then essentially necessary but I am wondering about all the other applications that come along in the Xcode Tools package, how do I find out what these programs do and if they may also be useful to me?
     
  10. aquajet macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #10
    I've noticed this problem after re-installing Leopard. Did your machine fall asleep after the install process completed? Meaning, did you have to wake up your machine before you rebooted after the install?
     
  11. Wowzera macrumors 6502a

    Joined:
    Oct 14, 2008
    Location:
    Brazil
    #11
    Well, if you do not develop, then most of them are not useful. I only use Icon Composer and SetFile.
     

Share This Page