Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

aloper

macrumors 6502
Original poster
Nov 23, 2015
449
457
Rocklin, CA
So this morning, there was a notification on my lock screen about "Verizon Plan is ready to be installed". Unlocking my phone, the settings app had a red 1 in the corner...indicating something like an update. Open the settings app and there was a line item for the same "Verizon Plan is ready to be installed". I clicked on it and it launched the cellular setup. Canceled out and now the settings indicator is gone and so is the notification...

My question is, why? I'm on AT&T...I haven't made any changes to my plan or changed any cellular option, in like...forever! lol. It seems weird that this should show up randomly, especially since I already have a cellular plan...Any thoughts as to why?
 

KaliYoni

macrumors 65816
Feb 19, 2016
1,022
2,273
One possibility is that an attacker was attempting to SIM swap you or port out your phone number.

In any case, it's good security practice to take these steps if you haven't already:
  1. Set a PIN for your SIM card (Settings/Cellular/SIM PIN).
  2. Contact AT&T and ask if you can add a PIN to your account that will be required for all account changes.
  3. Also ask AT&T if you can block any port out request that is not personally requested by you.
 

aloper

macrumors 6502
Original poster
Nov 23, 2015
449
457
Rocklin, CA
Just a quick update on this...The issue still persists...Every couple of hours, I get the IOS message, Verizon cellular plan is ready to be installed. If go into Cellular in settings, then add a new plan, the Verizon plan is sitting there, ready to be installed.

I called Apple first they had me do a full wipe and reset, and set up the phone as new...A few hours later, the messages started again. Called AT&T next to just make sure they didn't see anything weird going on with my account...nothing. Then I got passed to Verizon and they looked up my phone number, plus IMEI for both the sim and e-sim and came up with nothing. The Verizon tech rep was actually the most helpful of all. He ran out of ideas and recommended I try getting a new SIM, but said, he wasn't sure this would do much because in his opinion, it's the ESIM that might be the issue. Sure enough, went to a local AT&T store and got a new SIM. Walking out of the store, I got the Version is ready to be installed message...lol

So I'm writing this up in my Apple support ticket and will see what they recommend next...
 
  • Like
Reactions: NoGood@Usernames

bryanzimmer

macrumors newbie
Feb 22, 2022
1
0
@aloper any update on the cause or fix? I’m having the same problem, and I haven’t found any other posts on the Internet with the same issue. I called Verizon but they could find my SIM, eSIM, or phone number in their system. I submitted a ticket with Apple but haven’t heard back, and don’t expect to.
 

aloper

macrumors 6502
Original poster
Nov 23, 2015
449
457
Rocklin, CA
@aloper any update on the cause or fix? I’m having the same problem, and I haven’t found any other posts on the Internet with the same issue. I called Verizon but they could find my SIM, eSIM, or phone number in their system. I submitted a ticket with Apple but haven’t heard back, and don’t expect to.
I found this https://discussions.apple.com/thread/251981337
and did what was suggested:

Solved - under Settings - Cellular, it showed Cellular Plans - Secondary was Verizon, and it was toggled ON. I hit "Remove this Plan" - now shows Secondary Plan - NO SIM.

After doing that, I did a full reset of the phone and set it up as new. Haven’t had the problem since…
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.