Very challenging for you and me - Help with not able to recover iphone 3gs

Discussion in 'Jailbreaks and iOS Hacks' started by topclimber, Mar 22, 2011.

  1. topclimber macrumors newbie

    Joined:
    Mar 22, 2011
    #1
    Hi,

    I have got a unused iphone 3gs from friend's friend. There is no information can be obtained because the phone is stuck at recovery mod every time when reboot. So not sure if it's been jb or not, what firmware/ios version is, how to save the shsh etc, I tried to restore from itune, it fails with various error, eg: 1015, not eligible for this build, unknown reason, blah blah.

    So my question is: where do i start to make this phone usable, I don't mind to attemp anything because this phone at the moment to me is likely dead. Please can help simply point out what can possibly done to let me boot up the phone, even it can be only used to play music and view the photos, that's good enough for me.

    I will probably use tool to check firmware versions etc, but will this help?

    Thanks very much,

    Stephen
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    I'd say run Tinyumbrella while the phone is plugged in and let us know the installed firmware version and baseband version listed on the bottom of TU.
    And we'll take it from there.
     
  3. LeeTom macrumors 68000

    LeeTom

    Joined:
    May 31, 2004
  4. topclimber thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #4
    wow,people here are really nice and friendly! Bear with me for knowing nothing about all the tech terms.

    This is not related to the post high lighted.
     
  5. topclimber thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #5
    Guys

    I have done a few things, not sure why to do it but just googling, here's result:

    1. I tried the recboot to attempt fix the recovery mode loop, but it doesn't work

    2. I tried the irecovery script, it doesn't work

    3. Also, I used the just downloaded: TinyUmbrella-v4.30.03 to fix recovery, it doesn't work.

    All 3 ways lead to same result, after reboot the iphone, it quickly reenter the recovery mode(2 seconds)


    4. F0recast does not show any information at all (tried both mac version and win)

    So, to sum up, I got no backup of anything and I can't exit the recovery mode, so what to do next?

    Thanks,

    Stephen
     
  6. jdaniel macrumors 65816

    Joined:
    Mar 21, 2009
    Location:
    Ottawa, Canada
    #6
    So connecting it to TU doesnt show you any phone information?

    If nothing works... then I guess, what happens when you connect it to iTunes? Does it ask you to perform a restore? If it does then I guess that is the best option.....if it doesnt...then use pwnage tool as a timer to get your phone into DFU mode.. and just restore to whatever the current software is.

    There are lots of options to try if you want to assume its been jailbroken and you dont want to ruin the chances or whatever unlocking it... you can always use pwnage tool make some.....ipsws.. 4.1 , 4.21... edit hosts files to point to saurik.. just in case.. and try.. who knows.. you may get lucky... also if you dont have a att sim card you would need to activate it with a custom ipsw using pwnage tool anyways... so failing all that make sure host file points to apple.. and custom activate an ipsw... and put phone to DFU mode.. when prompted by itunes point it to the ipsw and restore...
     
  7. topclimber thread starter macrumors newbie

    Joined:
    Mar 22, 2011
    #7
    Yes,TU can not save shsh to my macbook. The only thing I did in TU is to try to do exit looping recovery mode by click fix recovery.

    Yes, itune asks me to restore. I have done this a few times already before starting this post. I attempted:

    1.0 I click restore button to let itune to do default, seems it has wiped everything from the phone and then stuck with 1015 error, (note that I didn't do backup because there has been any personal setup there yet, I thought a minimal ios up running should be no problem at all).

    1.1. then I tried to upgrade the itune to latest version and it failed again, not remember exact error, as mentioned it's one of (1015, not eligible for this build, unknown reason)

    1.2. then I tried to use windows to do the same, itune version is 9.x.x, failed again.


    I click auto button for above 1.0,1.1,1.2

    1.3. I downloaded a few apple's ipsw versions:3.1.3,4.2.1, xxx, all failed by cmd+restore

    2.0. Then I used pwnage tool (not sure what it will do), I followed wizard, it asked me to choose a ipsw, i was provided a ipsw which is in the update folder long time ago for my iphone3 (wonder what this step is for? and why 3gs need to use a ipsw from iphone), then it generate a ipsw in the desktop(do you call this custom ipsw? what is used for and when to use?), then I followed instruction to enter DFU mode and then do the restore again like exactly what I did in 1.3, all failed.

    I recall some posts ask to do restore a few times, but I am just not sure when is the right time to do that, feeling not on the right track.

    Note, I am not sure what that current software is because I haven't note down those info.(I should have read some posts before rushing into restore)

    3.0. I would assume it's not jb yet for the phone but just not sure. I have done that part to edit hosts without luck.

    So do you mean there can be anything done if it's not jbed? Can somebody simply explain what does pwnage tool to to make a ipsw? Also how can I know which version is possible for the phone to go jb etc?

    Thanks very much,

    Stephen
     

Share This Page