iPhone VERY slow downloading from Cydia while on WiFi. (LTE is very fast though)

Discussion in 'Jailbreaks and iOS Hacks' started by lukejc1, Feb 25, 2013.

  1. lukejc1 macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #1
    I'm having an issue with downloading from Cydia. Large files like themes take a very long time to download. Sometimes up to 10 minutes for a 30MB file.

    This is only an issue while on my WiFi (5 Ghtz network) and downloading from LTE is blazing fast.

    I thought this was an issue with my internet connection but a speed test shows download speeds of more than 40mbps over WiFi. And it only seems to be Cydia (and Theme It) that is very slow.

    Anybody have a possible explanation?
     
  2. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #2
    I've been experiencing the same thing. It takes FOREVER to download themes and I'm pretty sure it wasn't this slow on my 4S. I know themes are big but there is definitely something wrong. I've only tried on wifi.
     
  3. kwiky macrumors member

    Joined:
    Aug 8, 2011
  4. lukejc1 thread starter macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #4
    The theme I'm trying to get now is ayecon, which is on the Big Boss repo.
     
  5. lukejc1 thread starter macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #5
    The same thing is happening with Jaku also. It takes forever on my wifi but downloads very fast over LTE.

    Jaku is in ZodTTD repo.
     
  6. Adutrumque macrumors 65816

    Adutrumque

    Joined:
    Mar 8, 2012
    Location:
    Sweden
    #6
    Actually , biteSMS took me like forever on WiFi, iPhone 5 6.1.2. Really strange actually. Never happened before.
    BigBoss.
     
  7. Jakeblu macrumors regular

    Joined:
    Feb 20, 2008
    Location:
    UK
    #7
    Cydia is painfully slow for me too. Cant test the LTE because its not available at my home address.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Same here. It took like 5 minutes to download where other times its just 10 seconds.
    Weird...
     
  9. TG1 macrumors 6502a

    TG1

    Joined:
    Feb 21, 2011
    #9
    Have seen the same thing for certain packages. Weird.
     
  10. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
  11. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #11
    It might be the way repos were filtering or throttling connections to prevent things from crashing.

    Not to mention, the average LTE connection when you have solid service, likely exceeds average home WiFi speeds.
     
  12. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #12
    I don't know about the second part.
    I got a 25mb fios connection and the 6mb bitesms took forever.
    So maybe something else.
     
  13. lukejc1 thread starter macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #13
    I have a pretty fast internet connection. My speedtest app shows download speeds of 54mbps while LTE shows speeds of only 15mbps.

    Yet somehow downloading from repos is so much faster on LTE.
     
  14. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #14
    Wow that's horrible for LTE!

    Sorry :eek:
     
  15. lukejc1 thread starter macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #15
    I just tried again and it was more like 28. Pretty good but still only about half the speed of my internet connection.
     
  16. headcase macrumors 6502

    headcase

    Joined:
    Jul 4, 2007
    Location:
    Raleigh, NC
    #16
    People occasionally have also complained of a similar problem with downloading apps from iTunes (fast on cellular, slow on WiFi), while their other data pulls down very quickly. Some folks have noticed they needed to reset the DNS settings of their home router, if they previously were using a custom DNS service instead of the default DNS addresses that automatically come from your service provider (eg. using 8.8.8.8 and 8.8.4.4 for Google DNS, instead of leaving it as "default" in your home router).

    One way to verify if the speed problem on your iPhone is unique to Cydia, is to install a speed test app like this one and see what speeds and latency (ping times) you're getting on LTE vs WiFi:
    https://itunes.apple.com/app/id300704847
     
  17. co.ag.2005 macrumors 65816

    co.ag.2005

    Joined:
    Jun 17, 2009
    Location:
    Fort Worth, TX
    #17
    Thanks for the thread OP, I thought I was the only one experiencing this. The ayecon update today took forever over wifi. When I download things at work (LTE), it does seem faster.
     
  18. Enjoylife1788 macrumors 6502a

    Joined:
    Aug 22, 2011
    #18
    Guys,

    As someone mentioned, there was an issue with App Store apps too. And there are hundreds of pages with wifi issues.

    One solution that worked for me and I have tried almost all is that. Change the DNS to google's. that is 8.8.8.8 and 8.8.4.4.

    Also, as weird as it may sound, disable the cellular data while being on wifi. It actually solves the issue. I am en engineer and I know that technically it shouldn't matter. But I believed it after I tried. So guys give it a shot. And let me know.
     
  19. Eclipse538 macrumors regular

    Joined:
    Feb 18, 2013
    #19
    I use DNS on my 3GS thru google etc, but my gf doesn't, and she is experiencing extraordinary slow downloads, while I am getting very fast (15-20 mbs wifi) downloads still. Is this my fault with my DNS set up on my phone.

    Should I just reset the router?
     
  20. Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
  21. Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
    #21
    How do I change the DNS settings? I had someone from Time Warner come today and everything with the modem and router seem fine, yet my iPhone still is slow as hell with downloads. I'm getting network timeouts all the time also.

    4g works fine.
     
  22. lukejc1 thread starter macrumors 6502

    Joined:
    Feb 6, 2013
    Location:
    Wisconsin
    #23
    You can log in to your router settings and change them. Right now they are probably set to automatic. Which means they are set by your ISP. There should be an option there for you to set your own.

    Sorry I couldn't be more specific but I don't which router you have.
     
  23. Skizzy, Feb 27, 2013
    Last edited: Feb 27, 2013

    Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
    #24
    I have a netgear router/modem combo with Time Warner. I don't know how to get into the router settings.

    EDIT: I think I figured it out.
     
  24. Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
    #25
    I changed the settings to 8.8.8.8 and 8.8.4.4 and nothing changed download wise. =(
     

Share This Page