Resolved Very strange iPhone 4 issue.

Discussion in 'iPhone' started by AndrewR23, Nov 15, 2011.

  1. AndrewR23, Nov 15, 2011
    Last edited: Nov 16, 2011

    AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #1
    This is my moms iPhone 4.

    Attached are 2 screenshots. For some reason without WIFI, it won't send any emails. Or download any apps at all. Full bars and Full 3G.

    Everything works fine with WIFI. But there is no WIFI at her work.

    The email she uses is surewest.net
    http://forums.macrumors.com/attachment.php?attachmentid=312308&stc=1&d=1321411377

    http://forums.macrumors.com/attachment.php?attachmentid=312309&stc=1&d=1321411377

    The email is just an example. It won't send ANY emails to any email address.

    Also, it won't download any apps no matter what size they are.
     

    Attached Files:

  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  3. tremlock macrumors 6502a

    tremlock

    Joined:
    Jun 16, 2008
    Location:
    The Land of Cleves
    #3
    try turning off cellular data, waiting 15-30seconds then turning back on
     
  4. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
    #4
    Does she have the setting on to download apps and such over 3G? Looks like it might be off, it was off on my phone by default.
     
  5. PhoenixMac macrumors 65816

    Joined:
    Mar 7, 2010
    #5
    I think download apps on 3G is default off on all iphones
     
  6. AndrewR23 thread starter macrumors 68040

    Joined:
    Jun 24, 2010
    #6
    It was off. Turned it on. Still won't work.

    We did resolve the Surewest issue. The SMTP was smtp.surewest.com when it was suppose to be smtp.surewestauth.com
     
  7. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #7
    Apps over 20MB have to be downloaded over WiFi, but Half.com is only 4.4MB.
     
  8. AndrewR23 thread starter macrumors 68040

    Joined:
    Jun 24, 2010
    #8
    Yeah which is very strange it will not install. Did a full restore.
     
  9. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #9
    You already did or you are in the process?
     
  10. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #10
    This is an issue with her ISP. Their SMTP (outbound email) server will only accept emails from within their own network, i.e. it will work when she's on wifi at home (on her own Internet connection) but not elsewhere. Need to contact the ISP and see how they want it configured, probably a change in the iPhone settings to enable authenticated SMTP.
     
  11. AndrewR23 thread starter macrumors 68040

    Joined:
    Jun 24, 2010
    #11
    Yup, that was the issue.

    As for the app store issue, we restored the phone and started everything brand new. Worked the 2nd time. Strange issue.
     

Share This Page