Very weird starup issue...

Discussion in 'Macintosh Computers' started by quadraspleen, Dec 27, 2003.

  1. quadraspleen macrumors newbie

    Dec 27, 2003
    Poole, Dorset, UK
    Hi there,

    I am running a G4 Gigabit. I was given this machine in June by a colleague to see if I could get it working. When he gave it to me, it was running OS 9.1 with no firmware updates. It would only randomly boot to the OS and only randomly boot to CD. I managed to get into the OS and update the firmware as instructed to do so by Apple. I zapped the PRAM and removed the battery/hit the button etc. No joy.

    Apple could not tell me what was wrong bar "faulty hardware" .

    I was not convinced.

    I finally managed to get it up and running by changing the supplied DVD for a Plextor CD-RW I had lying around. At last! The machine would boot to CD.

    I wanted to dual-boot anyway, so I did an erase and install of OS 9.2.2 from CD to the first drive and then a fresh install of OS X 10.2.1 to the second HD.

    All seemed right in the world for a couple of months, then it became increasingly difficult to boot into OS 9 again. OS X has always been fine.

    I am now at the stage where I cannot boot OS 9 at all. I get a grey screen. I can hear the OS loading and if I place my hand on that drive during boot-up I am able to feel the drive working. After 3 mins or so, the drive becomes quiet. At this point, if I hit return, the drive starts up again, as if it was running drive checker. A minute or so later, it stops. If I now do the restart key combo, the mac restarts. No GUI though..:mad:

    What is weirder, is that if I try to boot from *any* OS 9 based CD's now I get the same thing happen!!!

    I am able to boot from all OS X based disks, like Disk Warrior, Norton's and OS X setup disks, both 10.2 and 10.3.

    I have tried installing OS 9 on the OS X disk and vice versa to see if it would make a difference but nope..

    I am completely stumped. My G4 doesn't like OS 9 anymore.

    I turn to you all in the vain hope that someone has experienced a similarly bizzarre problem.


  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Sorry, but that really sounds like a hardware issue to me--any time something gets progressively worse and isn't affected by changing the boot drive, it usually points to a hardware problem. OSX may just be more tolerant of it.

    That said, I'll try to be helpful with a couple of things that I'd try if it was my computer. Maybe there's something in here than you haven't tried yet.

    1) Weird theory: The PRAM has a weird resolution/scanrate set that OSX is ignoring, but OS9 (regardless of what it's on) is using. Holding down Shift at startup should aleviate this, though.

    2) You culd also try replacing the motherboard battery--might be the source of some hassle, and I've seen some WEIRD symptoms of failing batteries. Maybe OSX is more tolerant.

    3) Reset everything. Do a PRAM reset, as well as a full open firmware nvram reset. (Guessing you've already tried those, but never hurts to mention.) If you haven't tried doing it again after your OS9 problems started, you could go all out and unplug the computer for a while (push the power button after unplugging it to bleed it down, too), and push the motherboard reset button for good measure.

    4) Sounds like the issue is with video output, since the computer seems to be starting up from OS9 even though you can't see it. Maybe something happened to the video card; if you've got a spare around, try starting up from that. Or, if there are any frimware upgrades for the video card (not likely), you could try applying those--maybe it got corrupted, and OSX is using a software driver instead or something weird like that.

    5) Try swapping out RAM if you can; you might also check to see if OSX is recgonizing everything that's installed. Maybe OS9 is doing something weird with bad RAM, while OSX is just ignoring it. Unlikely, but you never know.

    6) Try unplugging/removing absolutely everything nonessential and see if it works. That is, unplug the optical drive, any peripherals, all but the OS9 hard drive, and anything else. Maybe even strip it down to bare RAM. If you do all that (make sure the jumper on the hard drive is set properly for a single drive), and it STILL doesn't work, the only things left are the video card or the motherboard.

    Good luck.

Share This Page