Very wierd problem with iphone 4s and wifi network

Discussion in 'iPhone' started by hakuna-matata, Jul 14, 2012.

  1. hakuna-matata macrumors 6502

    Sep 25, 2011
    Hi guyz, i got a wierd issue with wifi connectivity to iphone 4s. I am able to connect via wifi, run internet on safari and able to browse app store but whenever i download any app, it gives me error "unable to download app"..At the same instant, if i switch my wifi off and try it using 3g network, it gets downloaded and without any error if i download any other app.

    I am having same problem while installing cydia packages and even normal browsing on safari sometimes. Anybody experienced this before? I am guessing the problem is with my router settings coz earlier i was able to download apps.

    I have upgraded my wifi router to latest firmware. i have the following router.

    Following are the "internet'' and ''wireless'' settings ( --> interface setup--> )set by ISP. THANX:)

    Attached Files:

  2. Snakeyjake macrumors newbie

    May 9, 2012
    I've had the same issue for a while on ios 5 and still present on ios 6. Tried deleting wifi network and re-adding. Also I noticed it only happens if I'm updating more than one app and if I flick airplane mode on and off and retry it tends to work or if I wait for a few minutes it works. I think it's a wider spread problem as I saw a post on here a few months ago but it seemed to be deleted before anyone else reponded.
  3. Gav2k macrumors G3


    Jul 24, 2009
    I've only ever had this issue when my network channel was clashing with someone else's
  4. noteple macrumors 65816


    Aug 30, 2011
    Only had this problem with WPA TKIP

    Since switching to WPA2 and AES haven't seen it again

    Your mileage may vary
  5. a13x4nd3r macrumors newbie

    Mar 13, 2011
    Bandung, West Java, Indonesia
    hey man.. i have the exact same router interface as you..:D

    i use wpa2-psk with TKIP/AES encryption and not a single problem ever occurred to me
  6. hakuna-matata thread starter macrumors 6502

    Sep 25, 2011
    Lots of thanx guyz. I am gonna switch to wpa2-psk and AES but it's kind of greyed-out, so i might have to restore it to factory settings first. I had already tried to troubleshoot via instructions given on apple disscussion forum. If i am able to solve this issue. i would post my comment here so as to help others as it seems i am not the only person having this prob..thanx

Share This Page