Virtual PC Cursor Problem

Discussion in 'Mac Apps and Mac App Store' started by Elinor, Aug 27, 2004.

  1. Elinor macrumors newbie

    Aug 27, 2004
    I'm new to using Virtual PC so I'm hoping the solution to my problem is simply a setting somewhere... I've got VPC 6.1 running on a powerbook g4 with OS 10.3.3 and I installed XP Pro into Virtual PC. All went well until the day I used my powerbook in a lecture. I hooked it up to a digital projector and displayed a windows program onscreen. The next day I launched Virtual PC again only to discover, to my dismay, that the cursor was now not working.

    Specifically, it's the windows cursor that doesn't work. The mac side of things works as well as ever, but although a cursor shows on the Windows desktop, I cannot click on anything. I move it around and every once in a while a shortcut icon I have on the Windows desktop will light up as if I had selected it, but the cursor will at that point be positioned a good two inches below the icon. I can double-click at that point and the shortcut will launch the program it is supposed to, but because of the mismatch between where the cursor is showing on the window and where its "sweet spot" actually is, I cannot usefully use it to click on anything within the opened program. and because the cursor is so out of touch with its "sweet spot", I cannot use the "Start" menu located on the bottom of the screen to shut down Windows. I have to command click to the Virtual PC controls to log off and close down XP.

    What happened? And more importantly... How can I fix it?
  2. osprey76 macrumors 6502

    May 3, 2004
    Oklahoma City, OK
    I have not ever had this problem on VPC or a real PC. But, it seems that the projector may have messed with VPC's understanding of the size of the desktop. My thought would be to try changing the PC's resolution and seeing if this realigns the PC's world.
  3. Elinor thread starter macrumors newbie

    Aug 27, 2004
    Yes, I did have to mess with the screen resolution while setting up for the projector, but I set the resolutions back when I was finished. It's a good thought though...

    I have now changed the resolution (from within windows) which is difficult to do without a mouse cursor. Rebooted. No change

    I changed the resolution on the Mac side. Rebooted. No change

    I put resolutions both from within Windows and on the Mac side back to the orginal setting. Rebooted. No change.


    Am I going to have to uninstall VPC and XP and start over?
  4. Scottyk9 macrumors 6502a

    Jun 18, 2004
    Have you tried installing VPC additions (click the folder at the bottom of the VPC Window - should be able to access from the Mac side of things)? I had some cursor trouble prior to installing this (although more to do with responsiveness when moving between VPC and OS X).
  5. Elinor thread starter macrumors newbie

    Aug 27, 2004
    Yes, I have installed the "additions". In fact, I've re-installed 'em twice since the probs began to no effect.

    I'm getting mighty discouraged here...
  6. Elinor thread starter macrumors newbie

    Aug 27, 2004
    Gave Up fixing VPC Cursor Prob

    I tried several times to change the screen resolution display -- on both the mac and the windows sides. The windows side kept reverting, however.

    I un-installed VPC Additions and discovered that without the VPC-A's, the cursor on the windows side worked. I couldn't move files between the Mac and the Windows sides, but I at least there was a working cursor on the Windows side.

    Re-installing VPC Additions resulted immediately in the cursor problem (the sweet spot being up to 4 inches away from the point of the cursor icon) re-asserting itself.

    So for now, I do without VPC Additions.

    Nobody better ask me what I think of Virtual PC about now.
  7. Purpleshorts macrumors newbie

    Mar 12, 2004
    My cursor moves, but doesn't select.

    Virtual PC 5.04, Mac OSX 10.3... I can use the keyboard. I can move the mouse and see the cursor moving, but when I click and drag, a marquee of "marching ants" - a selection box you would see in Photoshop - is all I can get out of VPC.
  8. Mechcozmo macrumors 603


    Jul 17, 2004
    Sounds like a right-click almost.

    And just so you know, I havn't been aple to get VPC additions to install ever. They just never install right. :D

Share This Page