Virtual Voicemail Won’t Delete

Discussion in 'iOS 11' started by Laisha, Jul 20, 2018.

  1. Laisha macrumors regular

    Laisha

    #1
    Since March, I have been unable to delete my Visual Voicemails, in the main VM pane (where it says “Greeting” in the upper left) and in the “Deleted Messages” pane, where 16 of them remain.

    I ignored the problem because the last strange problem I had — a phantom alarm — had me wasting hours of my time trying stuff that didn’t work and I just live with it. I thought this would be the same kind of situation.

    Little did I know that’s dozens of voicemails were piling up at my providers — some of it very important.

    I’m about in tears.

    I found an old thread about the problem and tried the airplane mode fix — repeatedly — to no avail.

    I deleted all messages from my provider’s server, but the messages which are now apparently clogging my voicemail are still there.

    I have tried deleting from the iphone using every method there is.

    Apple is clueless — which I honestly don’t understand, as is my provider.

    I need help.
     
  2. NoBoMac macrumors 65816

    Joined:
    Jul 1, 2014
    #2
    Some WAGs: might try popping out and re-inserting the SIM card.

    Go to Settings > Phone > Change voicemail password and re-enter your existing password. I had an issue back in Nov/Dec timeframe where I was getting the occasional error where the phone could not access VVM. Just re-entering the passcode via "change password" cleared things up. Was a transient thing and have not seen since.

    When you said you deleted from the provider's servers, was this via some GUI/website, or, by dialing into voicemail old-school style? If website, might try using the dial-in method to see if that clears things.

    ADD: really big WAG: does provider have an account management app? And if so, does it have VM maintenance function? If so, might be something to download and try to clear things out.
     
  3. adamhenry macrumors 65816

    adamhenry

    Joined:
    Jan 1, 2015
    Location:
    On the Beach
    #3
    If I remember correctly, you have to go to the deleted messages panel and click edit in top right corner. Then you can delete the messages. Did you try that?
     
  4. Laisha thread starter macrumors regular

    Laisha

    #4
    Sorry for the delay. I tried the SIM reinsertion. Nothing changed.

    Tried the password change repeatedly over the past few days but get this message “Voicemaill Error / Try again later”. How much later is a mystery!

    I guess I’m old school. I dialed in like we did when bag phones were all the rage. :) Should I try to find an account management app?
    --- Post Merged, Jul 22, 2018 ---
    Yes. It says “CLEAR ALL” but it doesn’t.
     
  5. NoBoMac, Jul 22, 2018
    Last edited: Jul 22, 2018

    NoBoMac macrumors 65816

    Joined:
    Jul 1, 2014
    #5
    Sounds like something is messed up on cellco side. I'd contact them to see if they can reset your voicemail. Particularly in light of calling VM did not work re: delete.
     
  6. Laisha thread starter macrumors regular

    Laisha

    #6
    I spent a couple of hours on the phone with US Cellular. The put me thru all the paces again.

    I finally had the tech support guy get rid of Visual Voicemail.

    Problem solved. :)
     

Share This Page