Voice to text always capitalizes the first letter of first word...

Scott-n-Houston

macrumors 6502a
Original poster
Apr 27, 2008
895
121
Houston (duh)
This is driving me nuts. I use voice to text all the time, and prior to iOS6, I don't remember having this issue.

Essentially, if I'm talking out a sentence, but stop (with no period) to type in a word that I know it will not recognize (proper names, etc.), then resume with my voice, the next word will be capitalized regardless of whether the previous word ends with a period. This is driving me nuts, and I cannot find a setting to turn that off.

Googling and searching turns up massive amounts of issues with Droid issues, but nothing for iOS6.

Anyone else notice this? Any solution or setting that can change?
 

r2shyyou

macrumors 68000
Oct 3, 2010
1,755
4
Paris, France
This is driving me nuts. I use voice to text all the time, and prior to iOS6, I don't remember having this issue.

Essentially, if I'm talking out a sentence, but stop (with no period) to type in a word that I know it will not recognize (proper names, etc.), then resume with my voice, the next word will be capitalized regardless of whether the previous word ends with a period. This is driving me nuts, and I cannot find a setting to turn that off.

Googling and searching turns up massive amounts of issues with Droid issues, but nothing for iOS6.

Anyone else notice this? Any solution or setting that can change?
I'm not sure if this will work (not able to test at the moment) but there is an option in Settings that might do the trick:

Settings > General > Keyboard > Auto-Capitalization (toggle to OFF)

Hope that works!
 
  • Like
Reactions: Christo42

r2shyyou

macrumors 68000
Oct 3, 2010
1,755
4
Paris, France
Great thought!!

Sadly, it didn't work though.
That's too bad. Another thought would be to not stop the dictation and instead say either the word you know it'll get wrong or some other arbitrary word that you can correct afterwards. That'd probably be quicker anyway (or at least require less taps) since you currently enter the word manually anyway. Not sure what other options exist, if any.
 

Scott-n-Houston

macrumors 6502a
Original poster
Apr 27, 2008
895
121
Houston (duh)
That's too bad. Another thought would be to not stop the dictation and instead say either the word you know it'll get wrong or some other arbitrary word that you can correct afterwards. That'd probably be quicker anyway (or at least require less taps) since you currently enter the word manually anyway. Not sure what other options exist, if any.
Thanks. I may have to do that now. Sometimes that feels longer because sometimes getting the cursor in the right spot is a PITA. ;)
 

davidkajones

macrumors newbie
Nov 13, 2012
1
0
Automatic voice recognition technology is not still matured to produce accurate transcription for non-American accents, or with people speaking quickly or multiple speakers audio files. If you have more than one voice it is almost impossible to get a good transcript.Under this circumstance better go for manual transcription services
 

Gutwrench

Contributor
Jan 2, 2011
3,923
9,052
If I'm dictating and stop mid sentence the curser is set against the last word. If I manually add a space then continue to dictate it will (most times) capitalize the next word. If I leave the cursor positioned against the last word when I resume dictation it will add a space and (most times) not automatically capitalize next word.

So manually add the word and leave the cursor in place...don't add a space before resuming dictation. I've had decent results with this.
 

virginblue4

macrumors 68000
Apr 15, 2012
1,922
452
United Kingdom
If I'm dictating and stop mid sentence the curser is set against the last word. If I manually add a space then continue to dictate it will (most times) capitalize the next word. If I leave the cursor positioned against the last word when I resume dictation it will add a space and (most times) not automatically capitalize next word.

So manually add the word and leave the cursor in place...don't add a space before resuming dictation. I've had decent results with this.
If you say 'no caps' before speaking your text, it won't insert a capital letter. Hope that helps :)
 

RTWG

macrumors regular
Sep 12, 2008
135
103
This really bugs me too.

I reported it to Apple about a day after I got my iPhone 5.
 

Scott-n-Houston

macrumors 6502a
Original poster
Apr 27, 2008
895
121
Houston (duh)
If I'm dictating and stop mid sentence the curser is set against the last word. If I manually add a space then continue to dictate it will (most times) capitalize the next word. If I leave the cursor positioned against the last word when I resume dictation it will add a space and (most times) not automatically capitalize next word.

So manually add the word and leave the cursor in place...don't add a space before resuming dictation. I've had decent results with this.
This hasn't worked for me. It *should* work that way, but doesn't for me. :confused:
 

Gutwrench

Contributor
Jan 2, 2011
3,923
9,052
This hasn't worked for me. It *should* work that way, but doesn't for me. :confused:
Sorry for the bad information. It has worked for me in the past. i just tested it and it is not working for me now, just as you point out. I don't know the answer. I must have done something to cause it to work and misinterpreted it to be related to my cursor. Again, sorry for the misinformation.
 

Scott-n-Houston

macrumors 6502a
Original poster
Apr 27, 2008
895
121
Houston (duh)
Have you tried what I said?
Yes. It worked! Thanks!

----------

Sorry for the bad information. It has worked for me in the past. i just tested it and it is not working for me now, just as you point out. I don't know the answer. I must have done something to cause it to work and misinterpreted it to be related to my cursor. Again, sorry for the misinformation.
No apology necessary. Thanks for trying!

:D
 

pezmartinis

macrumors newbie
Jan 15, 2013
1
0
If you say 'no caps' before speaking your text, it won't insert a capital letter. Hope that helps :)
I have been so annoyed by this too. It seems like a small thing, but voice to text is all I do and I spend half the time changing caps manually so I don't look like an idiot. It can be time consuming, which negates my original purpose for using voice to text. Good tip on the "no caps" dictation. Still, I wish they would address this in the next update.
 

Christo42

macrumors newbie
Nov 7, 2015
1
0
[QUOTE="Settings > General > Keyboard > Auto-Capitalization (toggle to OFF)[/QUOTE]

That did the trick for me. Thank you so much!

When I downloaded an update, it automatically turned it off without me knowing about it. Your suggestion fixed it.