Wallpaper changes to default after restart

milkyway007

macrumors newbie
Oct 23, 2016
1
0
I was able to get around this problem by doing the following:

1. Select your wall paper from your choices in the Desktop folder.
2. Then move your cursor down to solid colors and just click on it
3. Close system preferences and restart.
4. Problem solved?
This worked for me, thanks! It's been bugging me for a while.
 

Veronica1122

macrumors newbie
Jun 26, 2017
1
0
Open Terminal (Applications/Utilities/Terminal.app) and paste this command



rm ~/Library/Preferences/com.apple.Desktop.plist



press 'return' on the keyboard.



Log out, log back in again. Change the wallpaper to what you want. Log out, log back in once more to test.



Any improvement?
 

dimension_z

macrumors newbie
Oct 3, 2017
2
0
Solution for me (and I believe for everyone):
- You can't use pictures from System Default Folder anymore (/Library/Desktop Pictures) - Maybe permission's fault.
- Put the Pictures you want inside /User/Pictures folder and Select the Picture you want from the Folders Option with + button in Preferences Window.
 

AngrieMunkie

macrumors newbie
Feb 6, 2018
1
0
I have had this issue too with my set up - kind of. The background prefs for screen #1 reverts to not changing at specified intervals/default, but screen #2 is just fine. I have found that it is a conflict with Wacom software/driver/stuff. In fact, Wacom software gets a little wonky when the system puts the screens to sleep - it doesn't wake up properly (pen jumps around, touch comes on and I can't shut it off, etc.) - Restart fixes everything but the background change, unless I do not turn on screen #2, the Wacom device, then the preferences stay.

I really don't use the iMac screen so I like it to swap out the images because I'm old and still believe if you leave one screen on without any action you'll burn it in, plus it helps keep my mind going with little micro breaks where I can glance up and look at a new purty picture (what can I say...)

This happens while running High Sierra on a late 2012 iMac with a Wacom 24" HD Touch Cintiq.
 

hellopupy

macrumors 6502
Sep 8, 2016
311
316
Los Angeles
I was able to get around this problem by doing the following:

1. Select your wall paper from your choices in the Desktop folder.
2. Then move your cursor down to solid colors and just click on it
3. Close system preferences and restart.
4. Problem solved?
I did this and it worked, just try this folks.