Wanting to unlock my new iPhone on new years - can I jailbreak it now?

Discussion in 'Jailbreaks and iOS Hacks' started by XIII, Dec 24, 2008.

  1. XIII macrumors 68040

    XIII

    Joined:
    Aug 15, 2004
    Location:
    England
    #1
    I bought myself a new 16GB white iPhone, and made sure it didn't come with the new software installed - so it should work with the soft unlock the dev team have coming out on New Years Eve. I've unpacked it as I couldn't wait, and what I was wondering was what the next step is? What is the ideal state for the phone to be in when it comes to needing to do the unlock - brand new out the box as it is now, or jailbroken? If jailbroken - can someone point me to a guide, I've read some very contradictory things!

    Thanks a lot, merry christmas.
     
  2. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #2
    Since the unlock application will come via Cydia, the phone has to be jb.

    You mean the stickied guide at the top of this forum isn't enough?
     
  3. XIII thread starter macrumors 68040

    XIII

    Joined:
    Aug 15, 2004
    Location:
    England
    #3
    Thanks, is this definite then? I may as well jailbreak now then.

    I have read through that guide twice now - so it seems the easiest way to do it would be for me to download the official 2.1 firmware from Apple if my iPhone hasn't come with it, restore to that, then use quickpwn? So long as I don't go near 2.2, downloading it or restoring to it or anything, my iPhone will be fine for unlocking?

    Thank you for the help - I am totally new to the jb/unlocking scene!
     
  4. cjm3113 macrumors 6502

    Joined:
    Nov 30, 2008
    #4
    Yes, it is very easy. Quickpwn does all the work. Any literate person can do it. Youtube also has plenty of demonstrations.
     
  5. jgunn macrumors regular

    Joined:
    Apr 7, 2008
    #5
    Don't use quickpwn!!! Use Pwnage tool as you can then select to not update the baseband. Update it to 2.2 without the baseband which is already deselected then you can unlock once the dev team release it.

    The best guide is Iclarified.

    http://www.iclarified.com/entry/index.php?enid=1558
     
  6. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #6
    The OP already said he was not going to install the 2.2 firmware so there's no problem using quickpwn.
     
  7. jgunn macrumors regular

    Joined:
    Apr 7, 2008
    #7

    i'm probably wrong but can you download old versions from apple. It seems they only have 2.2 on their site. If thats the case it's riskier to try it that way then to just use pwnage tool and 2,2
     
  8. The General macrumors 601

    Joined:
    Jul 7, 2006
    #8
    And the only reason he's sticking with 2.1 is because he clearly didn't know you can upgrade to 2.2 and keep the same 2.1 baseband which is vulnerable to the unlock that will be released on New Years.

    So, like the guy said, use PwnageTool to create a 2.2 firmware package that doesn't upgrade the baseband. That way he can have the most recent firmware and also unlock it.

    There's no reason not to want bug fixes and added features and stability. The only reason he wanted to - because he thought 2.2 wasn't unlockable - is erroneous.
     
  9. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #9
    I got my iPhone 3G Pay as You Go from the Apple Store, Regents Street, Central London on Monday 23rd. Week 48 model.

    It came with firmware 2.1. I've activated my O2 Sim Card (unlimited internet & wifi for 12 months).

    I've already Pwned it (2.1 still) and I'm just patiently waiting for New Years Eve!!! :cool:

    On a side note, yesterday my friend got a brand new 16Gb white from the same Apple Store as me. It came with firmware 2.0!!!
     
  10. XIII thread starter macrumors 68040

    XIII

    Joined:
    Aug 15, 2004
    Location:
    England
    #10
    Thanks - especially for the link to the guide. I've downloaded pwnagetool and I'll update to 2.2 following that guide. It's all clear to me now! Thanks a lot.
     
  11. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #11
    Thanks for speaking for the OP and telling us what he clearly knew and didn't know. You must have the same ability Matt Parkman does on Heroes only you can read minds remotely. Very cool. :rolleyes:

    You can still get the 2.1 firmware on the net, if not from Apple. QuickPwn is a little easier to use than the PwnageTool. The OP has a choice assuming the iPhone he got didn't already come with 2.2.
     
  12. XIII thread starter macrumors 68040

    XIII

    Joined:
    Aug 15, 2004
    Location:
    England
    #12
    Followed that guide - jailbroken on 2.2, all running very smoothly. Thanks everyone for the help. I understand that there were too options for me, both of which would've worked. I picked the 2.2 version as it's nice to have the latest firmware. Just eagerly waiting for the software unlock on New Year Eve now - from what I can see once it is released it should be very quick and easy!

    Merry Christmas.
     
  13. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
  14. jster25 macrumors member

    Joined:
    Sep 6, 2008
    #14
    So pretty much, I have a 2.2 Iphone 3g. I updated the firmware through itunes. I'm SOL when it comes to the unlocking software right? :(
     
  15. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #15
    It seems so.

    Go into Settings ➙ General ➙ About

    Check your Modem Firmware number. If it's 02.28.0 then you're out of luck.
    If you're on 02.11.07 or anything below then you're good to go.
     
  16. jster25 macrumors member

    Joined:
    Sep 6, 2008
    #16
    2.28 :mad::(
     
  17. jgunn macrumors regular

    Joined:
    Apr 7, 2008
    #17

    Don't stress, there are turbosims out now that can be used with the 2.28 baseband.
     
  18. cs03dmj macrumors newbie

    Joined:
    Dec 30, 2008
    #19
    How would one go from FW 2.1 & BB 02.11.07 to Jailbroken 2.2 (preserving baseband) using XP/Vista? It is not clear from any of the threads/tutorials I have seen whether this is currently possible, yet I am keen to unlock as soon as it is possible...
     
  19. Hing macrumors regular

    Joined:
    Mar 2, 2008
    #20
    I just brought a 3g and it have 2.1 firmware. I want to unlock it. So can some one please help me on what to do. if i use quickpawn on 2.1 will it change the baseband. i cannot use pwangetoll cuz i dont have a Mac computer.
     
  20. megamanbnmaster macrumors 6502

    Joined:
    Jan 26, 2008
    #21
    You can't unless you get a friend with a Mac and create a custom firmware using pwnagetool.

    You're out of luck unless you can get a friend with a mac to use pwnagetool and create you a custom firmware.
     
  21. cs03dmj macrumors newbie

    Joined:
    Dec 30, 2008
    #22
    Figures - cheers mm.
     

Share This Page