Warning: iMovie9 crashes repeatedly when accessing movies in Aperture3

Discussion in 'Mac Apps and Mac App Store' started by lifeis, Feb 21, 2010.

  1. lifeis macrumors newbie

    Joined:
    Feb 21, 2010
    #1
    I have just installed Aperture3 on my MacBookPro 10.6.2.
    I imported my iPhoto library to Aperture.
    I have hundreds of movies in Aperture from two Canon cameras.
    When I open iMovie, it correctly points to Aperture3 and begins to reference the movies in Aperture.
    One quarter of the way through this process, iMovie hangs and crashes.
    I tried several times, restarted and tried again. Crashes in exactly the same place.
    I reported this bug to Apple.
    1) Probably not a good idea for anyone using iMovie to upgrade to Aperture3 until Apple fixes this.
    2) Does anyone know how to start iMovie bypassing the automatic checking for new movies in Aperture? I have other movie projects I would like to work on.
     
  2. DDano macrumors newbie

    Joined:
    May 12, 2010
    Location:
    Regina
    #2
    Warning: iMovie9 crashes repeatedly when accessing movies in Aperture3

    I have the same issue just after installing iLife11. Running iMovie produces a scan of my 6+Gb Apreture3.1 library. It never recovers from that scan so I have to force quit it.

    You can get around it temporarily but doing the following:
    1. Open terminal
    2. Find your apreture library (default is in your ~/Pictures folder.
    3. sudo chown root:staff Apreture Library - enter your password when asked
    4. ls -al ~Pictures/Apreture Library to confirm that you no longer have assess to the file
    5. This effectively makes the library unavailable to you until you reverse the above operation.
    iMove no longer tries to read the file as it doesn't have access to it any more.
    To reverse use terminal and as before navigate to your Pictures folder or wherever you have your Apreture Library and do a sudo chown userid:staff Apreture Library. Substitute your user name with the userid.
    Access will be returned - but now iMovie will have access again and try and scan it for movies.

    Stupid bug - wish I knew what it was getting hung up on:mad:
     

Share This Page