Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

WARNING on wake up alarms in sleep schedule on watchOS 7!

GRT89521

macrumors member
Apr 24, 2018
99
97
It is because both watches are signed into the same account and both show the same bed time schedule. I had the same issue with my series 6 and series 3. I finally unpaired by series 3, as I found out I can wear the series 6 to bed and ot need to charge in the morning. I didn’t find a way prevent the series 3 from going on in WatchOS 7 and iOS 14. Even with the series 3 mutes, it would still chime.
The problem is I use both watches every day. The S6 (replaced my S3) is my workout/sleep watch; my S4 (Hermes) is my work and daily watch. So unpairing isn't really an option. I've had two Apple watches since I bought my S3 in 2017 and have never had this issue until upgrading to WatchOS 7.
 
Comment

Apple_Robert

Contributor
Sep 21, 2012
18,349
20,028
In the middle of several books.
The problem is I use both watches every day. The S6 (replaced my S3) is my workout/sleep watch; my S4 (Hermes) is my work and daily watch. So unpairing isn't really an option. I've had two Apple watches since I bought my S3 in 2017 and have never had this issue until upgrading to WatchOS 7.
Yea, I didn’t have the problem when my series 3 was on watch beta along with my series 5. For some reason, it all of a sudden became a problem. I like only having haptic feedback to wake up so, I had to silence the series 3 the only way I knew how.
 
Comment

Lennyvalentin

macrumors 65816
Apr 25, 2011
1,431
782
The major issue I had with the new sleep stuff is the DnD-on-a-schedule feature still overrides the go to bed reminder, so you never see it if DND turns on before bedtime hits. Fortunately the new system doesn't require DnD to be scheduled in order to work like the old bedtime feature did, so after a couple days of irritation and gnashing of teeth I realized this and turned off auto-DnD.

Also, there's a lot of options and toggles, more than just about any other feature in iOS... It feels a bit overworked and maybe not quite as intuitive as it could be perhaps I feel, but I suppose once you get it set up you can just leave it like it is and not have to bother with it again... Snooze can finally be turned off permanently which is a huge bonus for me because my brain just doesn't work properly right after waking up (later on is debatable too... lol), so more than occasionally I end up fumbling at the snooze button when what I really want is to turn off the alarm, and then there's no indicator the alarm is still in hiding, skulking around in the back waiting to pounce on me again 10 minutes later - like when I'm in the shower and have turned on the wet mode, so the alarm goes off again and keeps on going and going while I'm spinning the crown and the speaker is booping to eject water and the screen is still unresponsive. Ghhnnhh!

Took me two mornings interrupted by the alarm doing an encore (and me swearing at it for doing so) to realize that you have to dive deep into the settings to find the true permanently disable Snooze toggle; the toggle you get from the Clock app just affects this one time. And if you woozily activate Snooze it stays on even if you turn it off with the toggle afterwards. A bit of polish there would have been nice methinks.

*ahem* First world problems...
 
Comment

zeizei

macrumors newbie
Original poster
Jul 20, 2011
11
7
Looks like this was fixed in iOS 14.0.1 and/or watchOS 7.0.1. I upgraded my phone and my watch last night and this morning I was awakened to an audible alarm on my phone in addition to the haptics on my watch.
I don’t think so. I have updated the both OS as well, but if my watch is in silent mode and I open the sleep app on the watch it shows “alarm - haptics” and if I take the watch off from silent mode it shows only “alarm”.
 
Comment

nicho

macrumors 68040
Feb 15, 2008
3,641
2,519
Yea, I didn’t have the problem when my series 3 was on watch beta along with my series 5. For some reason, it all of a sudden became a problem. I like only having haptic feedback to wake up so, I had to silence the series 3 the only way I knew how.

For the benefit of @GRT89521 - the way to silence sleep alarms on your non-sleep watch is to go into settings on the watch and turn off "Use this watch for sleep".
 
Comment

Richard Peters

macrumors 6502
Jul 18, 2010
429
502
Surrey, UK
This sleep alarm thing is a pain.

My phone refuses to make any noise or vibrate in the morning, with just my watch vibrating (with the weakest vibration ever, despite being set to prominent). Pre-iOS14 /WatchOS7 my watch would vibrate and my phone would play early riser.

Even taking the watch off of silent mode in an attempt to at least get that to make some noise does nothing. Still just a weak vibration.

However I discovered the other day that weirdly, my S3, which isn’t being worn at at night, DOES play the alarm wake up tone. I left it on overnight and in the morning I could hear early riser blissfully coming from the drawer.

Normal alarms work on the phone though. Just seems to be the sleep one which is knackered.
 
Comment

BrettDS

macrumors 65816
Nov 14, 2012
1,305
431
Orlando
I don’t think so. I have updated the both OS as well, but if my watch is in silent mode and I open the sleep app on the watch it shows “alarm - haptics” and if I take the watch off from silent mode it shows only “alarm”.

All I can say is what happened to me... Before the 14.0.1/7.0.1 updates when my sleep alarm went off in the morning all I would get was haptics on my watch. After the updates I now get haptics on my watch and sounds from my phone. I didn’t make any changes anywhere. It just started working for me.

I will note that what you’re looking at on the watch is talking about how the alarm will respond on the watch itself. I’m not getting alarm sounds from the watch in the mornings... just haptics on the watch. I’m getting the alarm sound from my phone now, which wasn’t happening before the OS updates.
 
Comment

rafquiles

macrumors newbie
Sep 30, 2020
1
0
Florida, USA
I seem to be the only one who’s the target group of Apple sleeping app since I set it up first time and it’s working as expected. Alarm going off only on watch but haptic only, no sound. This is the way it should be. I’m happy.
After looking at a lot of the responses I must be the only one that hates it(really hate it). I don't want the alarm to go off on my watch, the haptic wake up drives me crazy. I want the option to just have watch completely silent track my sleep and then the iPhone Early Riser sound to wake me.

Can that be done? please and thank you :D
 
Comment

PsykX

macrumors 65816
Sep 16, 2006
1,027
507
What I realized through the beta cycle was that my Series 4 would use the haptic engine in the morning, on my desk, which was incredibly annoying.

Beta after beta, and then with the public GM version - the problem remained. Then I got a Series 6. Same thing.

Looked everywhere and never really knew how to turn this option off. I thought itwould work only if I worn the watch in bed.

I swear the sleep feature was even turned off and this was happening (to confirm) - but I turned it back off this morning. Will see what happens tomorrow...

On another note - didn't they mention at WWDC they had a study about sounds to wake you up and they changed all of the alarms for the Sleep Mode? Always though they were pretty aggressive.
 
Comment

zeizei

macrumors newbie
Original poster
Jul 20, 2011
11
7
All I can say is what happened to me... Before the 14.0.1/7.0.1 updates when my sleep alarm went off in the morning all I would get was haptics on my watch. After the updates I now get haptics on my watch and sounds from my phone. I didn’t make any changes anywhere. It just started working for me.

I will note that what you’re looking at on the watch is talking about how the alarm will respond on the watch itself. I’m not getting alarm sounds from the watch in the mornings... just haptics on the watch. I’m getting the alarm sound from my phone now, which wasn’t happening before the OS updates.

Ok that's really strange. It still doesn't work like that for me. Could you describe what are the exact settings you're using? Is your watch in silent mode? Is your phone in silent mode?

Also, when I go to Clock app on my phone and check the wake up alarm set by the sleep app it clearly says that "When you wear your Apple Watch to bed, the alarm will go off on your watch."
 
Comment

Fatyank

macrumors 6502
Jan 20, 2008
273
116
Chandler, Arizona
I have an alarm cat that wakes me up 5-10 minutes before my wake up alarm time. If I could teach her to tell time I wouldn’t need my watch. Cat 3.0!!! LOL
I do have an issue with the alarm tones. It is apparently defaulted to “Early Riser”. My alarm is set for same time every day 7 days a week. I select a different tone for different group of days, maybe for the next 7 days. I like to mix up the tones. The new tone will only play on the next morning alarm then defaults back to “Early Riser“ tone for the following day. Unless I select a new tone each night, I wil always get “Early Riser”. Is there a way to select a new tone and have it stay as wake up tone until I decide to change it??
 
Comment

SamboSoul

macrumors newbie
Nov 4, 2020
1
1
Fellas

I was wondering if I can use the sleep function on my series 6 when being put on the the nightstand and that it wakes me up with the beautiful new alarm sound? Right now I understand that if the watch is not being worn, the alarm goes off on the iPhone. But I actually don’t like to bring my phone into my bedroom and prefer to have the alarm going off on my watch but I don’t feel like wearing it at night.

Any solution for this?
 
  • Like
Reactions: jgz
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.