Watch OS6 >9 hours remaining


macrumors member
Original poster
Jun 13, 2013
I have an Apple Watch S3 and it requires updating to Watch OS6 before being able to pair to my girlfriends phone.

The time to download the update has varied between 8 hours and 5 days (yes, 5 days :eek: )

I have just installed the same update on my S4 and it took about 20 minutes.
Is anyone else experiencing slow download speeds or shall I just try starting again?


macrumors G3
Jul 11, 2009
I updated with the developer release of watchOS 6 last week and it took probably 5-6 hours for my series 3 watch to update. Along the way the watch app on my phone reported it wasn't on wifi (it was) and the ETA showed something like 7 days several times.


macrumors 6502a
Nov 29, 2008
Sydney, Australia
I tried to update but it said my iPhone needs to be updated first. I assume that means ios13.0 but I will wait for 13.1 next week.
Anyway it is a pity that the new watch faces won't work with AW3.


macrumors 65816
Nov 16, 2017
When I started my S4 upgrade it started out at like 8 hours. It probably took an hour in total. Probably not a good time to upgrade though.

Jack Neill

macrumors 6502a
Sep 13, 2015
San Antonio Texas
AW updates always suck, Ive had S1-S3 and with every major and a few minor updates, I have had to unpair and reset the AW just to get it to work again. I'm wearing my S3 Frontier right now in protest as my AW is busy resetting again.


macrumors G5
Nov 20, 2008
Ventura County
My S3 said 14 hours remaining at the beginning. The entire process including install took about 5 hours. Very much looking forward to the S5.


macrumors 6502
Aug 29, 2018
Chesapeake, VA
I have a Series 4 and I was looking at a 8 hour install. I killed the process, reboot both the phone and watch. Afterward it took 45 mins for the install.

Kahalu'u Bob

macrumors 6502a
Aug 9, 2007
I can't get it to update at all. I get a message that says I'm not connected to the Internet (I am). I suppose I'll wait a day or two.

lance link

macrumors newbie
Jul 17, 2019
tldr: Apple's upgrade process blows.

I upgraded my phone to IOS 13 this morning. After that, it informed me that my watch had to also be upgraded to watchOS 6 and that it would not work until I did. That really would have nice to have been told *before* moving to IOS 13.

So, before leaving for the day, I was forced to attempt the upgrade to get the watch working. The WatchOS update has failed 3 times. Each upgrade/download said it would take 12 hours (like others have reported) but each *only* took about 90 minutes.

I'm stuck on the third attempt. The phone said to line the watch face up with the view finder in the phone app but the view finder doesn't render. The bottom half of the screen is just black. So I switched to pairing manually.

Pairing manually is failing at the step on the phone "Enter the 6-digit code displayed on your Apple Watch" because no 6 digital code is displayed on the watch. Just the fuzzy silver flower that looks like fireworks.

Other problems in their work flow include being stuck in a loop on the phone between the "Get Connected" screen where it tells you to make sure the phone is connected to wifi or cell and to turn blue tooth on" and the "Start pairing" screen.

I'm sure that if I go to a nearby Apple store, I'll get no time because they're busy selling new phone.

****** process...

Super frustrating....

I guess I'll do what someone else said which is try again "in a few days".

Thanks for listening...

update: called support. We were not able to work through it. Have verified BT working on my phone. Next step is to very BT working on watch by trying to pair with another iPhone.

update: resolved: Been stuck in a state where the watch and phone would not pair via bluetooth. After verifying that my phone's BT worked and that other iphones could also not pair with my watch, I assumed it was an issue with the watch's BT. I restarted the watch several times but that didn't help. I also deleted the watch from Find My iPhone per instructions from Apple Support. That didn't help. Finally, while researching what all my hardware options were with the watch, I came across the instructions for the factory reset. I did this and as soon as it rebooted, the phone could see it and the upgrade process completed normally.
Last edited:


macrumors 6502a
Aug 6, 2011
The wife did her watch overnight and it was done in the AM. I had to reboot both watch/iphone a few times for the process to start all over again!?
WOS6 update was giving me about 8h+ estimated and then it was finished in about 2h. I left the house and I came back about 2h later and it was just done.


macrumors G5
May 18, 2008
I learned about this trick a couple years ago. If you’re on your WiFi network start the upgrade process. Once you get the time estimate turn off BT on your phone.

It *seems* (I have no way of confirming but this has always worked for me) that the process then just switches over to using the WiFi radios and the time drops dramatically. I went from 9 hours down to about 50 minutes.

When I first learned about this I was extremely sceptical, but it seems to have sped up the process every time I’ve upgraded going back to my S0 🤷‍♂️
Make of that what you will.