Weird double punctuation problem

Discussion in 'Mac Apps and Mac App Store' started by elliotay, Jul 17, 2004.

  1. elliotay macrumors regular

    Jul 9, 2001
    This is definitely one of the strangest problems I've encountered in OS X. Using when writing an email, I type a sentence and at the end of the sentence I type period and then hit space before starting the next sentence. When I hit space a second period shows up after the initial one folowed by a space. If I hit period wait a few seconds then hit space it still double punctuates. If I wait like 10 seconds then it doesn't happen. It only happens immeadiately after a word. If I type a random period it doesn't happen.

    After quite a bit of testing I've noticed that it happens with ANY punctuation, be it period, comma, semi colon, colon, dollar sign, number sign, carrot, anything. It doesn't happen with safari, word, AIM, or Adium. But it happens with and I've also seen it happen with Adium's Crash Log app. I've also noticed that has now stopped spell checking as I write. I checked the preferences and the box is checked to check spelling as I type.

    I'm using a Logitech MX700 keyboard. I thought it might be the keyboard, but I tried plugging in an apple pro keyboard and the problem persisted. It's got me completely stumped.

    I hope you all can understand my explanation. If anyone has any ideas I'm all ears. Thanks.
  2. realityisterror macrumors 65816


    Aug 30, 2003
    Snellville, GA
    weird.. have you tried repairing permissions?? not sure that that's the problem,, but it could be..

  3. elliotay thread starter macrumors regular

    Jul 9, 2001
    Forgot to mention it, but yes I did indeed try repairing permissions. No go problem still there.
  4. elliotay thread starter macrumors regular

    Jul 9, 2001
    It came back!

    So the problem has returned. Thinking back now. I'm pretty sure the problem was a result of my updating to the first version 10.2.8 and getting screwed. Now I fear this may be a result of 10.3.8. I'm using a different computer this time though, G4 Powerbook 1.5 gHz. The exact same problem occurs in except now it happens with spaces as well. I fixed the problem last time by installing to 10.3 when it came out. Someone please tell me I don't have to wait for Tiger to fix this. I can't possibly be the only person who's had this happen to them on two different computers.

Share This Page