Weird popup when my iPhone Xs is plugged into my iMac

212rikanmofo

macrumors 68000
Original poster
Jan 31, 2003
1,685
642
I am running Mojave 10.14.1 Beta 2, and I noticed this strange pop up saying something about my iPhone needing to download special software in order for iTunes to detect and use my phone. So I tried to download and install it but it keeps failing. I've never seen this message before and not sure if it's showing because I updated my iPhone to iOS 12.1 beta 2 or Mojave 10.14.1 beta 2.

Does anyone else get the same message? Why can't I update?
 

Lilydgg

macrumors member
Sep 20, 2014
40
8
I did yesterday, Im on 10.14 and plugged in my XS. The download worked for mine though.
The message said
Software update is required to connect to your iOS device
 

212rikanmofo

macrumors 68000
Original poster
Jan 31, 2003
1,685
642
Strange, the update keeps failing every time I try to download the update though. Will try again later, hopefully it works.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.