Well, I think I screwed up my Safari situation...bad.

Discussion in 'Mac Apps and Mac App Store' started by edcoche, Sep 8, 2010.

  1. edcoche macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #1
    Long story short, I haven't updated my macbook in awhile. I am running 10.5.8 and the reason I have not updated it in awhile is because the new iTunes is not compatible with my 1 generation nano (been in the lake twice.)

    Anyway, the reason I am writing this message is because I foolishly updated safari 4 (which worked perfectly fine) to the current version earlier today and after using it for about 2 minutes I realized that my 1password application is not compatible with the new safari (no button to press). Of course, I could have paid 25 bucks to get the newest version of 1password which is compatible with Safari 5 but I decided to try to delete Safari 5 myself and go back to the way things were prior to the update.

    I went delete crazy. I used AppZapper to take out safari and basically deleted anything safari related and emptied the trash. Upon trying to install safari 4 it tells me that it cannot install it b/c of a newer version on the computer. I then decide, well, maybe this trouble would have been worth the 25 bucks after all. I then tried to install safari 5.0.1 any was greeted by the same error message telling me about a newer version on my mac. I tried to install 5.0.2 and it says it cannot be installed unless I have leopard 10.6 which I do not want to do.

    Anybody out there who can help me get the rest of the safari stuff off my machine so I can reinstall Safari 4?? I would be a very happy man if I could get safari back to the way it was just 24 hours ago. I knew I was doing something stupid when going delete crazy and now I feel like a complete fool for not doing my research prior to all this.

    Please help me!
     
  2. edcoche thread starter macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #2
    Now we have a project - please help!

    Well, I realized that the reason safari 5.0.2 was not installing is because I downloaded the snow leopard version of it and now feel pretty dumb b/c right away I should have known that 10.6 would have meant snow leopard.

    Anyway, I installed the correct safari 5.0.2 and now when it loads up nothing happens--thanks to my deleting rampage. A browser gets loaded up and never loads a page :confused:. If I try to load firefox while safari is open it fails to load until I force quit safari. I dont know what I deleted but I recall a library/safari location being deleted at a place or so and also some 'meta' something file that had like 5000+ items in it when I was emptying the trash.

    I would be so very grateful if somebody can help me out so I can get safari working again and I am going to fork up the 25 dollars and get 1password 3 so I can have it with safari.
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
  4. edcoche thread starter macrumors regular

    edcoche

    Joined:
    Nov 2, 2007
    #4
    I do, normally. I recently had a little mission to see how many days I could go without restarting my computer, in an effort to prove to my friends Leopard's stability. The machine froze the other day while under a heavy workload but on the bright side it did last 130 days of action before that happened. I just ran it and am up to date on everything except iTunes 10, b/c of the waterlogged nano it only likes itunes 7, which I am fine with having.

    Anyway, I got it to work so thank you everyone who took the time to read my message and if you began to type up a helpful response to this message I want to extend an extra 'thank you' to you for taking the time and I am sorry for wasting your time.
     

Share This Page