Well this is odd - can't assign right Option as shortcut to show desktop

Discussion in 'OS X Mavericks (10.9)' started by pullman, Jun 25, 2014.

  1. pullman macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #1
    I have always assigned the right Option under Sys Prefs - Keyboard - Shortcuts - Mision Control to "Show desktop".

    But on my new Macbook (Mavericks) this doesn't seem to work. Oddly it works on my old Mac Pro which I upgraded to Mavericks.

    There's no exclamation mark to indicate a conflict. I can't assign the right Option key to any shortcut.

    What happens when I press the right Option (having clicked to activate the shortcut entry field) is that the cursor becomes a + sign.

    Any ideas? Many TIA
    Philip
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Go to System Preferences / Mission Control.

    You can there assign the right Option to "Show desktop".

    :)
     
  3. pullman thread starter macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #3
    Thanks Bruno. Like I said, that is exactly what I do but when I press right Option it doesn't "take", it is not registered. The cursor only changes to a + sign.
     
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #4
    No it's not what you did.

    Read my post carefully :D
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    And if that doesn't work then I'd go into the Input Sources tab and make sure that you have the correct layout selected. The right option key does nothing for me in the Shortcuts tab (it doesn't act as a +) so it's probably worth double-checking the layout.

    Edit: Two posts snuck in while I was typing that! But yeah, Bruno's suggestion says Prefs > Mission Control, not Prefs > Keyboard.
     
  6. pullman thread starter macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #6
    (sheepish smile) - it's the eyes that go blind first, as they say. Sorry, Bruno, I misread your reply completely. That works of course. I must be misremembering but I was sure I had assigned this under Keyboard.

    Any idea why this doesn't work under Keyboard, though?
     

Share This Page