What’s wrong with Apple’s support site ?

pawzlion

macrumors newbie
Original poster
Jan 14, 2010
2
1
I can’t find any more relevant place to post this, and I can’t post it on Apple’s support site for obvious reasons.

I can read discussions.apple.com if I get to it via a Google search. I can login to it. But I can’t click on any link to any of the groups or subgroups and expect to get there to post a question or read a group. It loads and loads and then says “Safari could not load the page due to too many redirects”.

I’ve tried Chrome and Safari on my iPad Pro, and I would think that it’s moot because all browsers use the same rendering engine but they don’t use the same history and cookie storage. I have this on my desktop computer too using Safari, but not on Windows. Windows works fine.

It’s irrelevant to go into what iOS version I use or anything like that because this is pretty obviously a server issue. I’ve been a commercial web developer since 1994 and I just can’t get my head around why this would be allowed to happen.

How much header manipulation are Apple doing that they can’t get their own fully up-to-date browser to talk to their own website ?

This is so dumb. And no, I’m definitely not going to wipe out all my cookies. That’s absurd. My cookies store important things. This happens whether I’m logged in or not logged in. It happens on both my iPads.

WHY, Apple ? I only even need to reach these pages on your discussion site because of another equally retarded problem. I just don’t get how the amazing “it just works” Apple that I once knew, can’t even make a simple web page work. It seems like NOTHING Apple produces anymore works right.

I am SO over this crap. I mastered cookies in the mid 90’s. Apple seem to be regressing to the point that they can’t even do no what I used to be able to accomplish on a 486 over 30 years ago. It’s just one thing after another with Apple these days. Now I can’t even join their discussion forum to discuss a technical problem because even just loading their discussion forum is apparently not possible on a brand new iPad Pro 2 12” with iOS 11.3.1 using Apple’s own browser. Really Apple ? REALLY ?
 
  • Like
Reactions: droidprincess

MacDawg

macrumors Core
Mar 20, 2004
19,708
4,274
"Between the Hedges"
Sorry you are having issues, but it sounds to me like you are blaming Apple for an issue that you don't fully understand yet. I have no idea what might be causing your problem, but given that fact that there are millions of other devices using Chrome and Safari as well as the hardware you are using and are apparently not experiencing these issues, you might want to consider that *maybe* it isn't Apple manipulating the headers to exclude their own browser.

Instead of a rant against Apple, maybe it would be more helpful to describe your issue, ask some questions and see if the good folks here on MR can help you to find a solution to the problem.
 
  • Like
Reactions: Glmnet1

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,538
16,044
Have you tried Chrome or Firefox, for example, on your Mac to see if they work?
 

Darth.Titan

macrumors 68030
Oct 31, 2007
2,709
301
Austin, TX
I’ve encountered this issue on other sites, not Apple.com.

Are you using any adblockers on your iOS device? That’s the best I’ve been able to come up with as an explanation.