What determines bootability on a FW drive?

Discussion in 'Macintosh Computers' started by beerguy, Nov 7, 2003.

  1. beerguy macrumors regular

    Aug 20, 2003
    My question stems from the fact that I have a FW400/USB2 (using FW mode) drive that does not appear to support booting. I can bless the drive all day long but selecting at the boot options screen gives me no love.

    Further more, I tried doing a fresh install to the drive and the installer says that the system can't start from that volume. Is it a specific chipset or what's the deal.

    Be gentle, I'm an old hat at Unix, but fairly new to Apple.
  2. daveL macrumors 68020


    Jun 18, 2003

    Jag or Panther? Did you partition the drive with Disk Utility? If so, did you select "Mac OS Extended" under the "Format" selection? With Panther, it would be "Mac OS Extended (Journaled)". You can't boot from UFS, as far as I know.
  3. beerguy thread starter macrumors regular

    Aug 20, 2003
    Panther (I actually also tried to install Jaguar on it with no change), used Disk utility to Format and it's Mac OS Extended (Journaled).

    It's very strange.
  4. beerguy thread starter macrumors regular

    Aug 20, 2003
    More info from system_profiler


    FireWire Bus:

    Speed: 400 Mb/sec Speed

    SAMSUNG SP0802N:

    Capacity: 74.56 GB
    Manufacturer: DMI
    Model: SAMSUNG SP0802N
    Removable Media: No
    Detachable Drive: Yes
    BSD Name: disk1
    OS9 Drivers: No
    Speed: 400 Mb/sec Speed
    Unit Spec Id: 24734
    Firmware Revision: 4.38
    Unit Software Version: 10483


    Capacity: 54.44 GB
    Available: 19.77 GB
    Writable: Yes
    File System: Journaled HFS+
    BSD Name: disk1s3
    Mount Point: /Volumes/Backup
  5. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Though I have little firsthand experience with this (I've only tried it a couple of times, and it always worked), I'd guess that it could stem from the drive's Firewire firmware.

    If there is some particular command or action whose support is required to boot from a Firewire drive, and that particular drive's firmware does not include it, then it wouldn't work. I know this is, or at least has been, true of some CD readers (not external--internal), and I see no particular reason it might not also be the case with Firewire.

    That said, I haven't heard of others with the same problem unless something else was wrong, so I'm not sure.

    Two other questions that I wasn't entirely clear on from your post:

    1) Did you try holding down the option key at startup and selecting the drive from the icons that appear? If it's a timing issue, this might work where the Startup Disk prefpane fails.

    2) Did you try cloning a working install to the drive using CarbonCopyCloner, with the "make bootable" flag checked in the preferences? That'd ensure that you have a working system on the disk.
  6. beerguy thread starter macrumors regular

    Aug 20, 2003
    I've tried both of the items you listed - no love.

    I CAN boot from my iPod so I don't think it is a problem with the iMac.
  7. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    You mean like the iPod still works as a music player? Or did you do a erase and install. I put panther on my iPod, but it wouldn't start up, it just got to the gray Apple, and the little gear just spun and spun and spun.
  8. beerguy thread starter macrumors regular

    Aug 20, 2003
    I can boot off the iPod after using CCC to copy the system over.. Installing to it didn't work.

    I still use the iPod for music.
  9. daveL macrumors 68020


    Jun 18, 2003
    I agree that it sounds like your FW firmware doesn't support booting. Try the option key during boot, as mentioned above. If the drive doesn't show up, I think you're hosed. Maybe look for a firmware update from your FW drive vendor.
  10. beerguy thread starter macrumors regular

    Aug 20, 2003
    The drive shows up up but won't boot if selected.....no firmware upgrade available.

  11. beerguy thread starter macrumors regular

    Aug 20, 2003
    The "official" word that I just got back from their Tech Support folks:

    Apparently just because the product documentation says that it's bootable doesn't mean that it is. Can you spell "Fraud?"

    The brand name of the drive is "Acom Data" and is stocked by at least Best Buy and CompUSA.

    Avoid them like the plague.

    If I can find my reciept this b@stard is going back to BestBuy.

  12. toughboy macrumors 6502a


    May 2, 2003
    Izmir, Turkey
    Acom Data.. I'll write this name down somewhere on my mind.. this is riddiculous.. I hope you can solve it by bringing it back...
  13. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    Booting from an iPod

    I also used CarbonCopyCloner to make my iPod bootable, and it didn't interfere with it's "iTune-ability". I did remove the iTunes folder from the backup list, though, because 1) there's no point in doubling up the backup; and 2) it would've thrown me over the 20GB size.

    Admittedly it was a SLOW-W-W boot device. But it did let me repartition hard disk - twice (long story, I won't bore you with it).

    I've left the iPod bootable (although with only a subset of my apps and files on it), since my music collection doesn't really need that much space.

    It's definitely a nice little tech-toy.

Share This Page