When Macbook pro 15" is connected to my HDTV screen, the picture quality is inferior!

Discussion in 'MacBook Pro' started by BazWollv, Apr 17, 2011.

  1. BazWollv macrumors newbie

    Joined:
    Apr 17, 2011
    #1
    Hello Apple community

    I need urgent assistance! Yesterday I purchased a Griffin mini display port to HDMI adaptor cable thing. Once I plugged in my HDMI cable into it and into my Sony TV screen (KDL-32S2000) 32" screen, with goes up to 1080i, the picture quality on the screen becomes hideous! Pixels are visible, large black edges around the computer screen, picture quality a bit worse. Everything is just more fuzzy and un-pleasent.
    I dont know what to do! I tried everything, i tried all the settings on system preferences- display, I seriously tried everything and I couldn't find the right resolution. What do I do? It says on my screen, 1355x768 resolution panel, but when I go into when I select something like 1440x900 or 1344x840 they dont look right. Please help needed, I did a lot of research and did not find a certain answer. Could it be the screen? Should I buy a new one?

    please much help needed

    Thanks Take care
     
  2. matwue macrumors member

    Joined:
    Mar 28, 2011
    #2
    Go into your System Preferences -> Displays -> Arrangement.

    Make sure to switch off "Mirror Displays". When disabled, you can set the resolution for your Macbooks display and the tv independently. Set the laptop to its native resolution (1280*800 for 13" or 1440*900 for the 15") and it will look normal.
     
  3. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #3
    What version of OS X are you using? You should see 720p, 1080i etc listed at the top of the resolutions list when connected to a TV if you're using Snow Leopard.

    Usually you have to do something with the TV screen settings but it depends on the TV. Pick the the resolution you want in your MBP's display settings and look for something like a "dot-by-dot" setting or a "native" (the term used by my Toshiba TV) resolution in the TV. And don't mirror (edit: as matwue mentioned above, but if you're not mirroring select 1080i for the TV and the standard native resolution on the MBP - not sure if that's what matwue meant but just clarifying it) .
     
  4. Auszero macrumors member

    Joined:
    Jul 18, 2009
    #4
    your tv's native resolution is 720p not 1080i, at least according to sony. Connect it and under system preferences -> displays there is a button "detect display" it should recognize the tv as a tv and give you the resolution option of 720p.
     
  5. BazWollv thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #5
    I understand I could change all those settings, but even when it fills the screen, it feels like it isn't a better resolution, just as if it takes what it sees from the small MBP screen and just stretches it on the screen, words are fuzzy and pictures too, I usually play games like world of warcraft, and when I try it picture quality is really low. Stuff like facebook the quality of pictures is very bad and thumbnails you can't see well.
     
  6. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #6
    It's not a better resolution. Remember, you're using a 32" screen with a native vertical resolution of 720, while your MBP is 15" with a vertical resolution of at 900 (or 1050 if you have the hi res display). Each pixel will be more than 2.5 times larger on the TV. All the fuzziness and anti-aliasing used to make your laptop screen look good will be visible on the TV unless you sit well back.

    The TV is fine for a display for sitting back and watching video. I wouldn't use my 1080p TV for work.
     
  7. vetman35, Apr 19, 2011
    Last edited: Apr 19, 2011

    vetman35 macrumors member

    Joined:
    Apr 25, 2010
    #7
    Been there with my bedroom Sony 32" 720p. Try a VGA cable and mDP to VGA. I have tried both HDMI and VGA and mine always looked better on VGA.

    The living room Sony XBR 46 is 1080p and I have a menu option called "Game Mode" that makes the picture look crisp like a monitor via HDMI. Check your TV menus.

    IMG_1036.jpg
     

Share This Page