When you tell siri someone is your brother

Discussion in 'iPhone' started by nhamp07, Oct 14, 2011.

  1. nhamp07 macrumors regular

    Joined:
    Oct 6, 2011
    #1
    she says do you want me to remember that ___ is your brother. I put yet but then it adds him as a manager in my contacts.
     
  2. shagam macrumors newbie

    Joined:
    Oct 14, 2011
    #2
    Having the same issue: the only relationship categories I'm permitted are spouse, assistant, and manager.

    Are you by any chance syncing your contacts with an Exchange server? I have a hunch there's some limitation related to Exchange syncing (perhaps specifically with Exchange 2003?) that's causing this weirdness. "Siri, go sit in the corner and think about what you did wrong."
     
  3. GraphicsGeek macrumors 6502a

    Joined:
    Sep 19, 2008
    #3
    Guys you don't need to do anything with your contacts. Do this:

    1) activate Siri
    2) say "call my brother"
    3) Siri asks who your brother is
    4) tell Siri which of your contacts is your brother
    5) Siri will then ask if she can remember that name as your brother
    6) you say yes

    That's it. The next time you ask to call your brother, it'll know who it is.
     
  4. shagam macrumors newbie

    Joined:
    Oct 14, 2011
    #4
    Sorry mate, but its just not the case for some of us, and judging by other threads, the ones having trouble are Exchange-sync'd contacts. Though you can still "train" Siri by saying "X is my brother" we only have a MANAGER, ASSISTANT, or SPOUSE field to save the relationship to. If we say "X is my brother" she responds "Save X as your manager?"
     
  5. shagam macrumors newbie

    Joined:
    Oct 14, 2011
    #5
    I found a fix: (this fix assumes you have setup your iCloud account to sync contacts...even if you don't have any stored in iCloud yet)

    1) Go to Contacts, then click Groups in the top left
    2) Go to your iCloud addressbook
    3) Create a new contact for yourself
    4) Save the contact, but then edit it: delete any "linked" contacts (these are listed towards the bottom)
    5) Go into Preferences -> iCloud and set "My Info"
    6) Again click Groups in the top left, choose iCloud addressbook, and select the new contact you made for yourself in step #3

    Now when you tell Siri "Joe is my brother" she'll remember!
     
  6. randallking macrumors member

    randallking

    Joined:
    Sep 29, 2009
    #6
    This is more of a workaround than a fix. This means that I have to keep two different contact records for myself, one in Exchange and one in iCloud. If my phone number, address, or other info changes, I have to remember to update it both places.

    Granted, the limitation may be on the the Exchange side rather than something that's Apple's fault.

    If it helps anyone, we're running Exchange 2007 here.
     
  7. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008

Share This Page