why 1080p (mp4) videos in iTunes not getting synced to my ipad?

Discussion in 'iPad' started by ansabakhan, Mar 21, 2012.

  1. ansabakhan macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #1
    i used Xilisoft Video Converter for Mac to convert MKV files to mp4 using profile for XBOX HD (which gives me 1080 mp4 video) it gets copied to itunes fine and plays on the new apple tv as well.. but wont copy to my new ipad ? what am i doing wrong?
     
  2. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #2
    What is the filename extension on these files? .MP4 or .M4V or leaving them as .MKV?
     
  3. ansabakhan thread starter macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #3
    mp4
     
  4. felixroqu3 macrumors regular

    felixroqu3

    Joined:
    Mar 5, 2012
    Location:
    New York, NY
    #4
    I sort of had this problem. I was flodding the forum with questions but no1 really helped. After hours of observation i finally figured out what was happening. I was converting some movies *i have 200+ mkv movies* to mp4. I added them succesfully to itunes and it played fine but when i connected my ipad it didnt sync to it. I checked the Movies and Tv shows tab and everything seemed to be fine but it wasnt syncing to my ipad. Then i converted some movies to MOV. The ipad takes MOV and MP4. But the same thing happened. And it was a mystery to me because i already had 2 movies in the ipad in those same formats and here i was converting movies to the same format and it wasnt syncing to it. And finally i figured it all out. The format is correct. The ipad takes MOV and MP4 but if it isnt in the correct "video codec" which is h.264 it wont sync to the ipad.

    Right click on the video file in itunes and click on "get info", then click on i think is "summary" i dont remember *im at work right now and dont have itunes installed* just click on the first tab. Then you will see the video information. There you will see the video format which is either MP4 or MOV AND you'll also see the "VIDEO CODEC" and since your converting it to MP4 your video format will probably be MPEG-4 instead of h.264. If its not in h.264 it WONT sync to the ipad. Use handbreak and use the ipad settings.
     
  5. ansabakhan thread starter macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #5
    ohh great info !... i am not near my computer but i know this is whart the problem is ...yes i did MPEG-4 , instead of h.264 ... the problem i see creating filles with handbrake is the film size is very large usually .. maybe i am not selecting the ipad settings
     
  6. felixroqu3 macrumors regular

    felixroqu3

    Joined:
    Mar 5, 2012
    Location:
    New York, NY
    #6
    Maybe. And MPEG-4 is the correct format. The problem is that its not in the corrent video codec. They are 2 different things. The video codec needs to be h.264. Are you a mac or windows user?
     
  7. Pressure macrumors 68040

    Pressure

    Joined:
    May 30, 2006
    Location:
    Denmark
    #7
    The problem is most likely the audio.

    The iPad have trouble syncing anything else than stereo audio.
     
  8. ansabakhan thread starter macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #8
    when you select ipad as your setting on handbrakedoyou only get stereo as your audio setting ?
     
  9. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #9
    Side note: I've just had a few videos that sync'd fine to my iPad 1 not sync to my iPad 3.

    Curious.
     
  10. Staindsoul macrumors 6502

    Staindsoul

    Joined:
    Apr 13, 2010
    Location:
    Texas
    #10
    Same here. Having syncing issues with new iPad. Audio and video are about a second off now when watching on new iPad. Hmm..
     
  11. ansabakhan thread starter macrumors 65816

    ansabakhan

    Joined:
    Mar 3, 2010
    #11
    i am on mac.. so how to fix the codec problem ?
     
  12. PeteAndolina macrumors newbie

    Joined:
    Mar 21, 2012
    #12
    I'm having the same audio/video sync problem. Video is about a half second behind the audio. Trying some workarounds but it clearly a software issue. Same file plays fine on my ps3. Wonder if apple knows about this. 5.11 please?
     
  13. felixroqu3 macrumors regular

    felixroqu3

    Joined:
    Mar 5, 2012
    Location:
    New York, NY
    #13
    Download Subler and that will fix your problem.
     
  14. brasileiro, Jul 16, 2012
    Last edited: Jul 16, 2012

    brasileiro macrumors newbie

    Joined:
    Jul 16, 2012
    #14
    Well, for me it only worked when i rendered my video in 1080 (1440x1080) using 1,33 pixel aspect ratio. When i was render in 1080 (1920x1080) the itunes could not sync my video cause it could not be played in my Ipad.

    Im using Windows with Sony Vegas and i have the New Ipad 4G. I hope it works.



    Sorry by my English, its not my native speaker.
     

Share This Page