Why do just a handful of websites time out for me?

Discussion in 'Mac Basics and Help' started by Apple!Fre@k, Sep 13, 2010.

  1. Apple!Fre@k macrumors 6502a

    Joined:
    Jun 25, 2006
    #1
    I've experienced this problem for TWO YEARS because I thought it was somehow related to my ISP, but now that I've moved to a completely different state and ISP I know that it can't be.

    For some reason, a VERY few number of sites won't connect for me and just time out and "fail." Nothing wrong with the site so I don't understand it. The main site I have this problem with is Twitter.com. If I go behind a VPN like Hotspot Shield, no problems and it's zippy. But without connecting to Hotspot Shield, it won't connect to the website. I have this problem with two other non-mainstream websites I visit.

    I encounter the same problem with the same websites on WiFi with my iPad and iPhone so I'm thinking it has to be something with my Airport Extreme and its settings.

    Does ANYONE have ANY idea what is going on here?
     
  2. Alfihar macrumors member

    Joined:
    Aug 7, 2010
    Location:
    UK
    #2
    In the Airport Utility in your routers settings go to the Advanced tab and then IPv6, check that the IPv6 mode is set to Link-local only. I had similar issues when it was set to Tunnel.
     
  3. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #3
    Yup. It appears it's always been set to Link-local. Any other ideas? :(
     
  4. shevans macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #4
    You could try setting a lower MTU figure, say 1450 to see if that helps.
     
  5. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #5
    How do I do that?
     
  6. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #6
    Anyone know how to set a lower MTU figure?

    Will someone help me out if I offer up a $10 Starbucks gift card?
     
  7. panoz7 macrumors 6502a

    panoz7

    Joined:
    Nov 21, 2005
    Location:
    Raleigh, NC
    #7
    I know nothing about this but here's what I found when I googled: http://support.apple.com/kb/HT2532

    The instructions are for Leopard but the same tab seems to exist for my computer running snow leopard.
     
  8. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #8
    Thanks - found it!

    I tried 1450 and 1400. Didn't do anything. And each time I went back to change the MTU after clicking "OK" it automatically changed back to "Standard (1500)"

    Something else to add to this that I just remembered: When a friend brought over a PC once, he connected to the same AE on the guest network and had no problem accessing the site I cannot -- Twitter.com. I am completely stumped. Why would a PC have no problem, but everything running an Apple OS does?
     
  9. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #9
    You could try Google public DNS (which you must set individually on each computer--Google has instructions). That seemed to help me when my ISP's DNS got unreliable for certain sites.
     
  10. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #10
    But it's not my ISP, it's my Airport Extreme. I was living in another COUNTRY and this was still effecting me there as it is here back in the US. There's no way it's the ISP -- it has to be the settings on the Airport Extreme. I'm just stumped on what to change.

    Does anyone think it has anything to do with the IPV6 thing?
     
  11. digitaldreamer macrumors newbie

    Joined:
    Aug 20, 2010
    #11
    If you type in the URL field twitter.com's IP: 128.242.245.20
    Does it work then?

    I'm confused that there are issues with the Mac, iPhone, and iPad, but a PC connected to the AE does not have this issue. Is your Mac connected via AE, too, or just to the router/switch?

    Have you tried turning off the Firewall on the router and/or AE just for kicks?

    MAJ
     
  12. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #12
    No dice. Get the same issue -- it just times out when trying to connect to that IP. My Mac is connected directly to the AE via wireless.

    Haven't tried turning off the firewall. How do I access that again?
     
  13. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #13
    I just wanted to add that I had what seemed like EXACTLY the same issue you're describing, and it turned out to be the IPv6 setting mentioned above in my case as well.

    Apparently your AEBS is set up properly, so maybe it's just a coincidence, but it's a mildly surprising one given the symptoms and similarity. Just for the heck of it, you might try going into the Network pref pane on your Mac, select the active network and click the "Advanced" button, then under the TCP/IP tab set IPv6 to Disabled.

    I have no idea if this would make any difference at all, but it occurs to me that all your Apple devices might have IPv6 set to Auto, while the PC that worked might not have had IPv6 support at all.

    Can't hurt to try--at worst it'll do nothing.
     
  14. Bernard SG macrumors 65816

    Bernard SG

    Joined:
    Jul 3, 2010
    #14
    Make sure your AE's firmware is up to date.
    Then, if the problem persists, create a new network from scratch using up-to-date AirPort utility.
     
  15. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #15
    AMAZING! THANK YOU BOTH! I don't know whether it was turning off IPv6 that did it, or updating the firmware, but I did both and it now WORKS! Happy day. :)

    Thanks so much, guys!

    Now that I have IPv6 turned off, what does it do? Did I need it for any reason? Does it have to do with my network security?
     
  16. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #16
    Answers: Currently not a whole lot, no, and no.

    IPv6 is a more advanced version of the basic system used to route traffic on a network. One of its big advantages is a larger number of available addresses, which in a theoretical future with an increasingly large number of devices connected to the internet would become necessary.

    In practice, this isn't thus far an issue, and it's nowhere near required, or even all that widely supported--the Internet is very much an IPv4 world still. It'll be a long time yet before it's going to be required.

    So the bottom line is it really isn't currently doing anything at all for you, and it's certainly not helping with security in any way.
     
  17. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #17
    Great explanation. Thanks!
     

Share This Page