Why does my iPod nano jump in the middle of the tracks ?

Discussion in 'iPod' started by icymountain, Jan 2, 2007.

  1. icymountain macrumors 6502

    Dec 12, 2006
    I have a problem with my iPod nano 2G (8 Gb black).
    It seems that it jumps to the next track in the middle of tracks. This happens in a reproducible way for maybe half of my tracks and always at the same point. For instance, for track X (length: 5 minutes), it will consider it finished after 1minute 12seconds whenever I play it. It reads the length of the track correctly, and still say that 3 min 48 secons remain after 1 min 12 sec, but still it will jump to the next one...

    This way, I have a 45 minutes series of tracks played in.... 12 minutes.

    The files were mp3 encoded (into AAC, I think ?) by itunes.

    What may cause this ? How to fix this issue ?
  2. icymountain thread starter macrumors 6502

    Dec 12, 2006
    I could also add another frustration with my iPod.
    It was formatted on my Mac and itunes did not leave me any choice, but HTFS+ regarding to the filesystem. I would prefer FAT, so that my iPod can be read with other computers or other systems with no problem (I mostly use linux and would really like to be able to mount my iPod under linux). I could not find a way to format it as a FAT filesystem with OSX (I could with the Diskutility but iTunes reverted to HTFS+ immediately!).
    I have not software under linux to initialize the iPod either.

    Any idea ?
  3. qbmcnabb108 macrumors member


    Dec 9, 2006
    Toms River, NJ
    My friends Pink iPod Nano does something similar. When you click on a song to play it, it skips to another song and plays that song. So you can't listen to most of the songs on the iPod. Is there anyway to fix this?
  4. icymountain thread starter macrumors 6502

    Dec 12, 2006
    It seems it is the same symptom. Is it with an iPod nano 2nd gen or 1st gen ? (mine is 2nd gen)

    If your friend tries something with Apple, I would be interested to know...
  5. rjphoto macrumors 6502a


    Mar 7, 2005
    Does it do the same thing with music encoded from CDs or bought from iTunes?
  6. pengu macrumors 6502a

    Mar 20, 2005
    Diddily Daddily...
    i have a simmilar problem with my ipod photo, and in itunes, maybe the "start at" and/or "end at" tags have been corrupted for those songs?
  7. bozigle macrumors regular

    similar problem with my video ipod and ripped music... also it start in the middle of the track rather than jump to the next one
    the same file on iTunes is fine though

  8. sushi Moderator emeritus


    Jul 19, 2002
    Here's what I would do to get an idea of what might be wrong.

    Select a particular song that is giving you problems on your iPod. Then do the following:

    - In iTunes, Check the Start At and End At tags to see if they are correct. If not, fix them, then try to play the song.

    - If the tags are correct, try playing the song in iTunes to see if it has the same problem.

    - If it plays okay in iTunes, try playing the song via the finder to see if it has the same problem.

    If the Start/End At tags are correct, and it will not play in iTunes or the Finder then I suspect that you have a corrupted file.
  9. Cromulent macrumors 603


    Oct 2, 2006
    The Land of Hope and Glory
    Bit of a long shot but have you tried turning on error correction in the import music preferences? Obviously you would need to import a CD again to test it out.
  10. qbmcnabb108 macrumors member


    Dec 9, 2006
    Toms River, NJ
    Well my friend and I use the same iTunes Library (mine) and the songs play fine on my iPod Video but they skip around on the iPod Nano 2nd Gen.
  11. drummerbooker14 macrumors 6502


    Jul 11, 2006
    this has happened to me, and it is usually an impartial file, so i guess to test it you could see if the song plays in itunes as well
  12. icymountain thread starter macrumors 6502

    Dec 12, 2006

    Sorry I did not reply faster: the last few days I had to go through windows installation woes (not for my computer) and the death of a laptop (mine :( ) and there is only so much energy I can devote to computer issues and remain sane (and my job is computer science research, which takes a lot of energy).

    - I am currently focusing on one album ripped from a CD, which presents the issue (I have many more tracks with the same issue). Here are the results:
    - iTunes has the same issue as my iPod; so I think this is either a file corruption problem or an iTunes/iPod glitch.
    - one of my friends tried and said both iTunes and his iPod work on this track, but I should check with him again (and check md5 and so on). I need to check the iTunes versions
    - MediaPlayer seems to work on this file with no problem (iTunes glitch ?).
    - I mainly use Linux software for music playback (xmms) and never came across this issue with any track with this soft (iTunes glitch ?).

    - Moreover, I have not had any problem with music ripped from CDs with iTunes so far. But I have not much experience either. I am currently ripping again all my CDs... :mad:

    Ideas about iTunes import issues ?

Share This Page