Why does Safari put an ".xla" extension on top of any ".xls" file?

Discussion in 'Mac Apps and Mac App Store' started by johnbro23, Mar 1, 2008.

  1. johnbro23 macrumors 6502a

    Joined:
    Apr 12, 2004
    Location:
    Pittsburgh, PA
    #1
    When I download an Excel file, Safari will add ".xla" to the end of the file, so it turns out being "filename.xls.xla". Any idea why this is happening, and if there's any way to fix it? Does this happen to anyone else?
     
  2. DCBass macrumors 6502

    Joined:
    Jan 23, 2004
    Location:
    Washington, DC
    #2
    Same Problem.. and we're not alone

    Hey John,

    I hadn't noticed with excel files, but I do have the same problem with ms word files getting appended as .doc.dot files when i download them with safari. Here's another discussion here on macrumors about it. There's a link in there to a discussion thread on Apple's support board where a guy posted an applescript he wrote to fix the extensions in one fell swoop. However, it doesn't look like it actually solves the root of the problem from what I can tell.

    Hopefully the problem will be fixed in the next version of Safari.

    Best,

    DCBass
     
  3. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #3
    For me, this started after I installed Office 2008. There is no damage to the file. It will still open in Excel just fine. If you delete the .xla extension, then the file will display the standard Excel document icon.
     
  4. kvasir macrumors regular

    Joined:
    Oct 9, 2007
    #4
    I almost posted this on Friday. The thing I don't like is that when the extra extension is on there, quicklook no longer works. It drives me mad, but thanks DCBass for the AppleScript and the link. Saves me some time.
     
  5. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #5
    I just noticed this when I downloaded some word documents.

    I downloaded a Excel file the other day that had it too - but I just thought that the author had done it accidentally.

    VERY annoying though, no script would help me.
     
  6. numlock macrumors 68000

    Joined:
    Mar 13, 2006
    #6
    i have the same problem.

    I am downloading an excel file from my bank and when downloaded with Safari it has the xls.xla extension but in Camino just .xls extension. However the results are the same when i try an open the files in neooffice. They dont open in the spreadsheet program but rather as a read only file in the word part.

    Where is the problem? is it the banks fault for choosing some format, neooffice or am i making some mistake?
     
  7. debbie700 macrumors newbie

    Joined:
    Mar 31, 2008
    #7
    set up test machine and got different results

    My Mac is running 10.4.11 and is an IMAC G5 running Safari 3.1 (beta). When I went to a specific site to download word docs they were all downloaded with the .dot appended after the .doc.

    I had a machine sitting here that had Leopard (10.5) on it (Power Mac G5) but did not yet have a version of Microsoft Office on it - I went to the web page I had previously downloaded docs from - using Safari (3.0.4) I downloaded one of the word docs - it downloaded with only the .doc extension on it. When I launched the document it opened in TextEdit without any problems.

    Then I installed Office 2004 on the machine. Downloads still appeared as .doc and opened fine in Word and TextEdit.

    Then I ran the Apple Software Update since I had 10.5 on this machine - upgraded to 10.5.2. Still no problems. Upgraded Safari to 3.1 - still no problems.

    Then I installed Office 2008. Ran the Office 2008 updater through the latest 12.0.1 updater. Downloaded 3 more forms - no problem - downloaded as .doc and opened without any problems.

    This was a machine that we did a clean install on - there may be another problem at work here. The clean install may be an indicator here - my IMAC was upgraded from Panther to Tiger and from Office 2004 to 2008.

    I don't know if this will help but thought I would pass it on. Sometimes a clean install removes a lot of gremlins.
     
  8. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #8
    I'm not gonna reinstall the OS to fix what appears to be a small mistake in a configuration file.

    This MacBook has only ever had Leopard on it - no other Mac OS will run on it.
     
  9. Mhaddy macrumors 6502

    Mhaddy

    Joined:
    Oct 26, 2005
    Location:
    Canada
    #9
    I suppose I'll chime in here -- I'm currently experiencing this too, and it only occurred after I installed Office 2008 with the latest update. Very annoying!
     
  10. AlejandroMoreno macrumors newbie

    AlejandroMoreno

    Joined:
    May 27, 2008
    Location:
    San Rafael CA
    #10
    How do I get rid of the .xla extension?

    I'm new to Macs, just bought a macbook last month. I had no problem opening excel files before. I installed Office 2008 from day one when I bought it. All of a sudden this week it starts appending the .xla extension. Is there a ¨fix¨ for this?

    Is it Safari? If so, can I use Mozilla on my mac, and would that be a way around the problem for now?

    Thanks!
     

Share This Page