Why is my GPS symbol suddenly on all the time? I closed all apps, nothing running

Discussion in 'iPhone' started by wadawow, Aug 13, 2011.

  1. wadawow macrumors member

    Joined:
    Jul 24, 2011
  2. illini71 macrumors member

    Joined:
    Dec 28, 2010
    #2
    This happen to me also. I could not figure so i restored from a backup. That got rid of it.
     
  3. jonrando macrumors 6502a

    Joined:
    Jun 22, 2011
    #3
    Did you recently update the Weather Channel app? There is a known problem that they are working on fixing where it keeps the arrow on your status bar.

    If you go to Settings > General > Reset > Reset Location Warnings, it'll go away.
     
  4. TonyC28 macrumors 65816

    TonyC28

    Joined:
    Aug 15, 2009
    Location:
    USA
    #4
    If you have the Weather Channel app it's probably the absolutely horrible update they just did.
     
  5. illini71 macrumors member

    Joined:
    Dec 28, 2010
    #5
    I shut off local weather and the gps still stayed on. I use the city option now. I still could not pin point it. I dont know if it was on or if the arrow was just stuck.
     
  6. Shockwave78 macrumors 65816

    Shockwave78

    Joined:
    Jul 10, 2010
    #6
    I had the same problem there a couple days ago, i went through my apps location settings one by one and it ended up being "the weather channel max" that was constantly doing something.
     
  7. Littleman macrumors regular

    Littleman

    Joined:
    Mar 5, 2008
    #7
    Happening to me also :(

    Think I've narrowed it down to Navigon.
     
  8. scotty588 macrumors 6502

    Joined:
    Jan 2, 2007
    Location:
    Carlsbad, CA
    #8
    The Okcupid app has recently updated with a new locals feature and it keeps the GPS location icon in the top bar.
     
  9. AIP5 macrumors 6502a

    Joined:
    Aug 2, 2011
    #9
    If you are running iOS 5 beta, then that is probably related to the Reminders.app. For some reason (probably why it's called a beta), Reminders.app uses a crapload of battery and GPS if you have a Geo-fenced reminder on there. So your best bet could be to just go in Settings -> Location Services -> and turn off permission for Reminders.app. That's what had happened to me a while back.
     
  10. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #10
    This. I deleted it and downloaded Fahrenheit. Much better.
     

Share This Page