Why my iPhone won't do automatic backup??

Discussion in 'iPhone' started by yalag, Jun 24, 2012.

  1. yalag macrumors 65816

    Nov 18, 2007
    A long time ago I used to plug my iphone into my iMac's usb every night before bed. It does automatic data sync AND backup.

    Now we moved to wireless syncing with itunes. Great. Except now it will only sync every night and NOT backup. So what am I suppose to do now? Go back to USB syncing?

    And no, I don't want to use icloud backup because my icloud is full and also I want my backup local.

    Anyone have a fix? I don't want to manually click backup, is there any reason why it isn't automatic along with sync?
  2. yalag thread starter macrumors 65816

    Nov 18, 2007
  3. takeshi74 macrumors 601

    Feb 9, 2011
    Posting a question does not guarantee answers on any discussion forum site.

    Have you looked for any similar threads?


  4. aristobrat macrumors G5

    Oct 14, 2005
    Poking around on Apple's support site, I can't find anything that indicates that backup should work automatically over WiFi. :confused:

    Both of their general iOS backup documents have been updated since iOS 5 came out (which added that feature):
  5. itsmemuffins macrumors 68040


    Jun 23, 2010
    If you have iCloud backup it won't backup in iTunes on your computer. It's either or not both.

    If you want both you need to manually back it up on your computer by clicking on your iPhones name.
  6. Daveoc64 macrumors 601

    Jan 16, 2008
    Bristol, UK
    My iPhone never automatically syncs over Wi-Fi, I always have to click the "Sync" button.

    When I do that, it does a backup as well.
  7. yalag thread starter macrumors 65816

    Nov 18, 2007
    But that's not suppose to be the case. It should automatically sync when you charge. Can anyone confirm that it doesn't automatically backup? Why? Why did apple do this?
  8. Azzin macrumors 601


    Jun 23, 2010
    London, England.
    (If I've understood you correctly), isn't there an option in iTunes that you tick/untick, that says something like "Prevent devices from synchronising automatically when connected to iTunes"?

    If that is ticked, then your IPhone will not do anything when you connect it.

    So check that's unticked and make sure iTunes is running, then when you connect your iPhone at night it should sync.

Share This Page