Why won't discs that I created with DVD Shrink on my PC mount on my Mac?

Discussion in 'Macintosh Computers' started by RHMMMM, Nov 23, 2005.

  1. RHMMMM macrumors member

    Aug 9, 2005
    I'm trying to watch some of the DVD Backups that I created on my PC with DVD Shrink and the discs won't mount to the desktop. Of course, nothing will play it since it's not mounted. I thought it might be a disc type problem, but I have tried ones on DVD+R and DVD-R and none of them mount.

    They ALL show up in the Disk Utility and it reads the correct disc type and the volume name.

    Why won't it mount - can anyone help?!
  2. khisayruou macrumors 6502a


    Aug 21, 2004
    Try a different brand of dvds.
    Try a different software to burn them with.
  3. JackRipper macrumors regular


    May 14, 2002
    South Carolina
    I periodically have the same problem with commerical DVDs.

    Logging out and back in fixes it for me, give that a shot if you haven't already.
  4. RHMMMM thread starter macrumors member

    Aug 9, 2005
    Restarting/logging out fixed it, thanks! I was getting pretty frustrated!

Share This Page