Why won't my rMBP see some of my usb devices

Discussion in 'Mac Basics and Help' started by inscrewtable, Apr 9, 2016.

  1. inscrewtable macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #1
    I have an rMBP with a 7 port usb hub, 3 usb 3.0 and 4 usb 2.0

    The hub is powered and plugged into the usb 3 port on the mac.

    I have a usb 2 desktop external powered HDD that is seen by the mac when plugged into this hub, and other peripherals are also seen like a wacom tablet and a focusrite audio interface. However I have two WD Mypassport 2.5" external usb3 drives that the mac will not see when plugged into the usb 3 ports.

    If I plug any other device into these usb 3 ports it is seen so I know the ports are working.

    When I plug the WD hard drives into the port they boot up and start spinning but will not load to the destop. If I plug them directly into the mac they are seen on the desktop no problems.

    Any clues as to if there are some cache files or other such nonsense that I could delete to get the mac to see these WD mypassport ultra drives? There was a time in the past when they were seen by the mac through this very same hub, but suddenly not any longer. Naturally I've tried rebooting in various ways, with the hub plugged in and without the hub plugged in and then plugged in after booting.

    Every other peripheral I have works fine in all the ports excecpt these two WD drives.
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    You didn't tell us -which version- of the OS you are using.

    I've heard that El Capitan "breaks" some USB hubs.
    Some work.
    Others have problems.

    Probably the only way to fix this is to use a different hub that is known to work.
    But one could spend considerable money by trying several different ones before finding one "that worked".

    My suggestion:
    Just use whatever connection scheme "works" for you.
    If the two WD drives need to be plugged -directly- into the Mac to work, well.... that's just what you have to do.

    Sometimes one has to do.... what one has to do...
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #3
    Things you didn't mention testing:

    1. USB cables.
    Switch the cables between the working drive and the non-working ones.

    2. Isolation.
    What happens when the only thing plugged into the USB hub is the non-working HD?
    In other words, does isolating the HD from other USB peripherals change anything?

    3. Other hubs.
    As Fishrrman noted, there can be problems specific to a peripheral model. What model is the one that's failing, and do you have another hub you can try?
     
  4. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #4
    Reboot while keeping the USB 3.0 devices connected.

    Right now if you check System Information for USB, you will probably not see the USB 3.0 hub, just 2.0.
     
  5. inscrewtable, Apr 10, 2016
    Last edited: Apr 10, 2016

    inscrewtable thread starter macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #5
    Well, I know the cables are fine because they work plugged into the mac. Tried it with everything else unplugged, didn't work upon reboot. None of the other items, Focusrite, Wacom or Wallwart enabled desktop usb 2.0 drive need any power so I tried them all with the power to the hub unplugged and they still all worked fine. So I tried the unplugging everything again then unplugging the hub from the Mac and from the power supply then I plugged the Ultra HDD in and of course nothing, then I plugged the usb power back in and the Ultra spun up, which it always does anyway. Then I plugged the hub into the mac and it booted up on the desktop which it has not done for ages. Then I plugged everything back in including the two Ultra HDD's into the hub rebooted the mac and everything loaded on the Desktop. So it's suddenly all working again.

    Not only that but I did a Blackmagic Speed Test and the WD Ultra drives were reading 90mb/sec read and write which I've never seen them do before in the hub, best I could ever get out of the hub when it was working was about 40mb/sec, to get 90mb/sec I needed to plug them directly into the mac.

    I can't work out what has happened here but whatever happened it's all working better than ever now!! It must be the magic of macrumors, or something.

    EDIT: Ok this is weird. After I did all this I noticed I forgot to plug the power back into the rMBP. So I plugged it back in. Everthing was still working fine I could demount and remount the Ultra drives using Disk Utility. However when plugged the power back into the Mac, Blackmagic Speedtest was reading 20mb/sec read write on the Ultra HDDs, which is what I used to get in the past when it was working. I unplugged the power cable to the Mac and rebooted and the Ultra HDD's tested back at their full speed 85mb/sec this time.

    So it looks like when the Mac is plugged in to power that this is what is causing the Hub to not work properly. Does this sound normal?
     
  6. dan1eln1el5en macrumors 6502

    dan1eln1el5en

    Joined:
    Jan 3, 2012
    Location:
    Copenhagen, Denmark
    #6
    left or right side USB ?
    I found there is a better connection and more power on the right USB port and the left one some times don't want to read Thumb drives.
     
  7. inscrewtable thread starter macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #7
    Actually it turns out to be more weird than I thought. After the Mac started seeing my WD Ultra HDD's again, I tried unplugging and plugging the power to the Mac while booting to see if I could replicate the problem. Once I get full speed from the Ultra HDD's, unplugging and plugging power back into the mac makes no difference. But then at some point the speed with drop from 85mb/sec to 40 then to 20 or less. I cannot fathom at this stage what is causing it. However when they dropped down to 20mb/sec this morning after a reboot, it took a further reboot with the power cord to the Mac unplugged to restore it to 85mb/sec. But at least they are both mounting properly which they have not done for about six months. At this stage I have no idea what is causing this problem. All this is with the peripherals plugged in.
     
  8. inscrewtable thread starter macrumors 65816

    inscrewtable

    Joined:
    Oct 9, 2010
    Location:
    Australia
    #8
    UPDATE:

    OK I have separate power switches on each usb port, and I need to turn them off because the drives won't power down otherwise even with the rMBP shut down. Today I booted up the Mac with the separate drive switch off, when I turned on the Mac and then switched on the power to the drive, it did not boot. So I unplugged the power to supply to the Mac and then switched on the power to the external drive and it did boot. So that seems to be the problem.

    However I am still left with the recurring problem that sometimes the drive will only operate at 20mb/sec and sometimes at 85Mb/sec and I am unable to work out what is causing this.
     
  9. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #9
    Isn't that drive simply borked? I'd replace it if I were you.

    If you want to out some effort into it, use a utility to display the SMART status of the drive. It's a hassle since I don't think you can read these out over USB, so you'll have to place it in a desktop machine or a thunderbolt enclosure.
     
  10. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #10
    OP:

    As I said in reply #2 above, sometimes you just have to find which connection scheme "works" -- and use that one, instead of trying to use schemes that -don't work- ...
     

Share This Page