Why won't Safari's security certificates for Facebook and Twitter verify on my connec

Discussion in 'macOS' started by rsherid, Mar 31, 2012.

  1. rsherid macrumors member

    Jul 9, 2009
    At least once every day a box pops up that says Safari can't verify the identity of Facebook.com or Twitter.com. I click OK or adjust it so say "Always Trust" and then Facebook.com goes blank. The blank page will say access denied, page cannot be found, etc. etc.

    All the fixes I've found online seem to be Windows-based and suggest making sure the clock/time is accurate. Mine has always been up to date so that's not an option for me. I've also disabled pop-ups as per a suggestion and that didn't do anything.

    So if there's any Mac users with knowledge of security certificates, it'd be a huge help.

    SAFARI 5.1.2
    SNOW LEOPARD 10.6.8
  2. rsherid thread starter macrumors member

    Jul 9, 2009
    This is currently happening when I go to YouTube.com :(
  3. rsherid thread starter macrumors member

    Jul 9, 2009
  4. nataliathespy macrumors newbie

    Apr 2, 2012
    Just got this to work for me

    I am sorry that no one has responded to you! I have had the same question, and was finally able to get something to work (at least, I have not had any further errors....yet). I am running Snow Leopard (OS X 10.6.8) and Safari 5.1.4.

    Follow the "Network Preferences" instructions found in this thread: https://discussions.apple.com/message/15663396#15663396
    Open Network Preferences.
    Click the active network card (wired or wireless).
    Click Advanced...
    Click Proxies tab.
    Enable "Auto Proxy Discovery" (probably enabled already) and enable "Automatic Proxy Configuration".
    Click OK
    Click Apply
    Close Network Preferences
    Restart your MAC​

    If that doesn't work, give these instructions a try: http://forums.macrumors.com/showthread.php?t=1168976. I did not have the "com.apple.security.revocation.plist" file in that directory--I only had "com.apple.security.plist", so I left it as is.

    Hope that helps. :)
  5. rsherid thread starter macrumors member

    Jul 9, 2009
    Hey, thanks. I tried your first suggestion, which worked until today. I didn't have ~/Library/Preferences/com.apple.security.revocation.plist, but I have deleted the regular .plist file before (as suggested) and still doesn't work.

    This is becoming a major problem - what if I wiped my hard drive and started a new OS X user account?
  6. rsherid thread starter macrumors member

    Jul 9, 2009

Share This Page