Why won't the MP3 play on Mac's IE or Firefox? Fine on Safari!

h0kie99

macrumors member
Original poster
Jul 31, 2004
82
0
VA
I am using this code to embed an MP3 file into a pop-up window (don't worry, I've got controls and the user actually has to click to start the song):

<embed src="mysongname.mp3" autostart="true" hidden="true" loop="true">

This works fine on IE and Firefox for PC and it works fine on Safari for Mac. The problem is that the song does NOT play on IE or Firefox for Mac! Any suggestions?

Thanks!
 

rozwell

macrumors regular
Apr 17, 2004
240
1
<embed src="mysongname.mp3" autostart="true" hidden="true" loop="true"/>

that might be it... browsers are lame like that and that slash could be it.
 

mnkeybsness

macrumors 68030
Jun 25, 2001
2,511
0
Moneyapolis, Minnesota
are you surrounding the <embed> tag with an <object> tag?

Code:
<object height="24" width="100">
<embed src="mysongname.mp3" autostart="true" hidden="true" loop="true" />
</object>
 

h0kie99

macrumors member
Original poster
Jul 31, 2004
82
0
VA
Still no go...

I just tried both suggestions... still works fine on PC's IE & Firefox and Mac's Safari, but not Mac's IE or Firefox. I have been googling and get nothing but crap. Any other suggestions?

My current code:
<object height="1" width="1">
<embed src="mysongname.mp3" autostart="true" hidden="true" loop="true" />
</object>

Hmmm...
 

ChicoWeb

macrumors 65816
Aug 16, 2004
1,120
0
California
Have you checked your MIME types on your server? I had the same issue w/ a clients server. It would just display the text URL.
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
Have you tried it on someone else's computer other than yours, to make sure it's a FF/IE/Safari code issue and not an issue with the settings of FF and IE or of QT on your computer? For instance link it and let us try?

Also, if you force-specify the MIME type by adding:

type="audio/x-mp3"

to the <embed> tag, what happens?
 

h0kie99

macrumors member
Original poster
Jul 31, 2004
82
0
VA
Not working yet...

I tried all suggestions in this thread and the song still won't play on Mac's IE or Firefox. It is not just my computer that won't cooperate, it is also the client's computer.

Try this link... http://www.saucedesigns.com/sauce.html (warning - the song will immediately play when you load this link... it is designed to be a pop-up that is initiated by the customer... so they don't have to listen if they don't want to!)

You will see how the song plays on Mac's Safari, but not IE/Firefox. It plays just fine on IE/Firefox for PC, so it isn't a browser-specific thing, it has to be a Mac/PC thing. Right?

Thanks!
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,641
12
Grand Rapids, MI, USA
Yes, I can confirm that it does what you describe in Safari and DPA2 on my computer. But... did you try putting in the type="audio/x-mp3" in the tag? I didn't see that in the source code as it is now.
 

ChicoWeb

macrumors 65816
Aug 16, 2004
1,120
0
California
h0kie99 said:
I tried all suggestions in this thread and the song still won't play on Mac's IE or Firefox. It is not just my computer that won't cooperate, it is also the client's computer.

Try this link... http://www.saucedesigns.com/sauce.html (warning - the song will immediately play when you load this link... it is designed to be a pop-up that is initiated by the customer... so they don't have to listen if they don't want to!)

You will see how the song plays on Mac's Safari, but not IE/Firefox. It plays just fine on IE/Firefox for PC, so it isn't a browser-specific thing, it has to be a Mac/PC thing. Right?

Thanks!
Define your mime type in .htaccess...If that doesn't work, call your host and they may be able to update the settings..